Cleanup xf86-input-mouse package makefile.
[openwrt/svn-archive/archive.git] / Xorg / xorg / driver / xf86-input-mouse / Makefile
index 1fa0a456cf46b5fddff7c8a6f671cd47c1a9bd22..3acbef90f506f8a01f7792a0b2e251a6533ecc02 100644 (file)
@@ -1,71 +1,39 @@
-# 
+#
 # Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# blogic@openwrt.org
+# $Id$
+
 include $(TOPDIR)/rules.mk
 
-PKG_BASE_NAME:=xf86
 PKG_NAME:=xf86-input-mouse
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 PKG_VERSION:=1.3.0
 PKG_SOURCE_URL:=http://xorg.freedesktop.org/releases/X11R7.4/src/driver
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_BUILD_DIR=$(BUILD_DIR)/Xorg/$(_CATEGORY)/${PKG_NAME}-$(PKG_VERSION)/
+PKG_BUILD_DIR=$(BUILD_DIR)/Xorg/$(_CATEGORY)/$(PKG_NAME)-$(PKG_VERSION)/
+PKG_BUILD_DEPENDS:=randrproto inputproto xproto
 
 include $(INCLUDE_DIR)/package.mk
 
+PKG_INSTALL:=1
+
 define Package/xf86-input-mouse
   SECTION:=xorg-driver
   CATEGORY:=Xorg
   SUBMENU:=driver
-  DEPENDS:=+xserver-xorg @DISPLAY_SUPPORT
+  DEPENDS:=+xserver-xorg
   TITLE:=xf86-input-mouse
   URL:=http://xorg.freedesktop.org/
 endef
 
-define Build/InstallDev
-       DESTDIR="$(1)" $(MAKE) -C $(PKG_BUILD_DIR)/ $(MAKE_FLAGS) install
-endef
-
-EXTRA_CPPFLAGS= -I$(STAGING_DIR)/usr/include/xorg \
-               -I$(STAGING_DIR)/usr/include/X11/ \
-               -I$(STAGING_DIR)/usr/include/ \
-               -I$(STAGING_DIR)/include/
-
-EXTRA_CFLAGS+= $(EXTRA_CPPFLAGS)
-
-acvar=$(subst -,_,$(subst .,_,$(subst /,_,$(1))))
-
-CONFIGURE_VARS +=DRI_CFLAGS="-I$(STAGING_DIR)/usr/include/X11/dri/" ac_cv_file__usr_share_sgml_X11_defs_ent=yes \
-       sdkdir=$(STAGING_DIR) 
-
-define Build/Configure
-       (cd $(PKG_BUILD_DIR)/$(CONFIGURE_PATH); \
-       if [ -x $(CONFIGURE_CMD) ]; then \
-               $(CP) $(SCRIPT_DIR)/config.{guess,sub} $(PKG_BUILD_DIR)/ && \
-               $(foreach a,dri.h sarea.h dristruct.h exa.h damage.h,export ac_cv_file_$(call acvar,$(STAGING_DIR)/usr/include/xorg/$(a))=yes;) \
-               sed -i "s|sdkdir=.*|sdkdir=$(STAGING_DIR)/usr/include/xorg|g" $(PKG_BUILD_DIR)/configure ;\
-               $(CONFIGURE_VARS) \
-               $(CONFIGURE_CMD) \
-               $(CONFIGURE_ARGS_XTRA) \
-               $(CONFIGURE_ARGS) \
-               CPPFLAGS="$(EXTRA_CPPFLAGS)" ;\
-       fi \
-       )
-endef
-
-define Build/Compile
-       make -C $(PKG_BUILD_DIR)
-       DESTDIR=$(PKG_INSTALL_DIR) $(MAKE) -C $(PKG_BUILD_DIR) $(MAKE_FLAGS) install
-       find $(PKG_INSTALL_DIR) -name *a | xargs rm -rf
-endef
-
 define Package/xf86-input-mouse/install
-       $(INSTALL_DIR) $(1)/usr/lib/
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/* $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/usr/lib/xorg/modules/input
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/lib/xorg/modules/input/mouse_drv.so \
+               $(1)/usr/lib/xorg/modules/input/
 endef
 
 $(eval $(call BuildPackage,xf86-input-mouse))