libX11: depend on DISPLAY_SUPPORT
[openwrt/svn-archive/archive.git] / Xorg / xorg / lib / libX11 / Makefile
index 8f40857412a01bc75ed91b878aa88e92e673294a..6468b04e31316c5ca44af0d91532a631471b7811 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2009 OpenWrt.org
+# Copyright (C) 2007-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -24,10 +24,10 @@ PKG_BUILD_DEPENDS:=xproto xextproto xf86bigfontproto kbproto inputproto \
 include $(INCLUDE_DIR)/package.mk
 
 define Package/libX11
-  SECTION:=xorg-lib
+  SECTION:=xorg-libraries
   CATEGORY:=Xorg
   SUBMENU:=libraries
-  DEPENDS:=+libXdmcp +libXau
+  DEPENDS:=+libXdmcp +libXau @FEATURE_drawing-backend_libX11 @DISPLAY_SUPPORT
   TITLE:=libX11
   URL:=http://xorg.freedesktop.org/
 endef
@@ -74,9 +74,13 @@ endef
 
 define Package/libX11/install
        $(INSTALL_DIR) $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/share/X11
        $(CP) \
                $(PKG_INSTALL_DIR)/usr/lib/*.so* \
                $(1)/usr/lib/
+       $(CP)  \
+               $(PKG_INSTALL_DIR)/usr/share/X11/* \
+               $(1)/usr/share/X11
 endef
 
 $(eval $(call Feature,libX11))