Retain symlinks. $(INSTALL_*) copys the contens of a file, so if we want to keep
[openwrt/svn-archive/archive.git] / Xorg / xorg / lib / libXdmcp / Makefile
index e96cf04b3abec85a0e69ca3d0b735a6e0270ae8f..19082bd7744224a8efd15bc278b0ab4ad1fd8372 100644 (file)
@@ -9,7 +9,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libXdmcp
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libXdmcp
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 PKG_VERSION:=1.0.2
 
 PKG_SOURCE_URL:=http://xorg.freedesktop.org/releases/X11R7.4/src/lib/
 PKG_VERSION:=1.0.2
 
 PKG_SOURCE_URL:=http://xorg.freedesktop.org/releases/X11R7.4/src/lib/
@@ -32,7 +32,7 @@ endef
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/{lib/pkgconfig,include/X11}
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/{lib/pkgconfig,include/X11}
-       $(INSTALL_DATA) \
+       $(CP) \
                $(PKG_INSTALL_DIR)/usr/lib/*.{so*,a,la} \
                $(1)/usr/lib/
        $(INSTALL_DATA) \
                $(PKG_INSTALL_DIR)/usr/lib/*.{so*,a,la} \
                $(1)/usr/lib/
        $(INSTALL_DATA) \
@@ -45,7 +45,7 @@ endef
 
 define Package/libXdmcp/install
        $(INSTALL_DIR) $(1)/usr/lib
 
 define Package/libXdmcp/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(INSTALL_DATA) \
+       $(CP) \
                $(PKG_INSTALL_DIR)/usr/lib/*.so* \
                $(1)/usr/lib/
 endef
                $(PKG_INSTALL_DIR)/usr/lib/*.so* \
                $(1)/usr/lib/
 endef