Retain symlinks. $(INSTALL_*) copys the contens of a file, so if we want to keep
[openwrt/svn-archive/archive.git] / Xorg / xorg / lib / libXfont / Makefile
index ebcbc5258d437181a6c02760a80841b60c6c9409..51ef83ffb85f5517d2f4d351ee8f9bebb3cdd81d 100644 (file)
@@ -9,7 +9,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libXfont
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libXfont
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 PKG_VERSION:=1.3.3
 
 PKG_SOURCE_URL:=http://xorg.freedesktop.org/releases/X11R7.4/src/lib/
 PKG_VERSION:=1.3.3
 
 PKG_SOURCE_URL:=http://xorg.freedesktop.org/releases/X11R7.4/src/lib/
@@ -33,7 +33,7 @@ endef
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/{lib/pkgconfig,include/X11/fonts}
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/{lib/pkgconfig,include/X11/fonts}
-       $(INSTALL_DATA) \
+       $(CP) \
                $(PKG_INSTALL_DIR)/usr/lib/*.{so*,a,la} \
                $(1)/usr/lib/
        $(INSTALL_DATA) \
                $(PKG_INSTALL_DIR)/usr/lib/*.{so*,a,la} \
                $(1)/usr/lib/
        $(INSTALL_DATA) \
@@ -46,7 +46,7 @@ endef
 
 define Package/libXfont/install
        $(INSTALL_DIR) $(1)/usr/lib
 
 define Package/libXfont/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(INSTALL_DATA) \
+       $(CP) \
                $(PKG_INSTALL_DIR)/usr/lib/*.so* \
                $(1)/usr/lib/
 endef
                $(PKG_INSTALL_DIR)/usr/lib/*.so* \
                $(1)/usr/lib/
 endef