libSM, libXpm: dependency fixes
[openwrt/svn-archive/archive.git] / Xorg / xorg / lib / libXpm / Makefile
index c72be242743e62a63d29a817970bf2b60041edde..05186d13025832cdcab6d81da0c36be15e878e90 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libXpm
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_VERSION:=3.5.8
 
 PKG_SOURCE_URL:=http://xorg.freedesktop.org/releases/individual/lib/
@@ -26,11 +26,13 @@ define Package/libXpm
   SECTION:=xorg-libraries
   CATEGORY:=Xorg
   SUBMENU:=libraries
-  DEPENDS:=+libX11 +libXt +libXext
+  DEPENDS:=+libX11 +libXt +libXext +libSM
   TITLE:=libXpm
   URL:=http://xorg.freedesktop.org/
 endef
 
+TARGET_LDFLAGS+=-Wl,-rpath-link=$(STAGING_DIR)/usr/lib
+
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/{lib/pkgconfig,include/X11}
        $(CP) \