xorg-kdrive: Disable xsdl autoconf check
[openwrt/svn-archive/archive.git] / Xorg / xorg / xserver / xorg-kdrive / Makefile
index b9f76b000c0456b0a9cfcba5455ec8827b9c0b1d..fbb1d19a7c56204bb49bfb8eeab7ed44184665c5 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,11 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=xserver-kdrive
-PKG_RELEASE:=1
 PKG_VERSION:=1.7.1
+PKG_RELEASE:=1
+
 PKG_SOURCE_URL:=http://xorg.freedesktop.org/releases/individual/xserver/
 PKG_SOURCE:=xorg-server-$(PKG_VERSION).tar.bz2
 PKG_BUILD_DIR:=$(BUILD_DIR)/Xorg/xserver/$(PKG_NAME)/xorg-server-$(PKG_VERSION)/
+PKG_MD5SUM:=dda7842467cda6018fdc87e6002e4db1
 
 PKG_BUILD_DEPENDS:=randrproto renderproto fixesproto damageproto xcmiscproto \
                                   xextproto xproto bigreqsproto resourceproto \
@@ -26,6 +28,7 @@ PKG_CONFIG_DEPENDS := \
     CONFIG_X_TSLIB CONFIG_X_COMPOSITE \
        CONFIG_X_XINERAMA CONFIG_X_XCALIBRATE
 
+PKG_FIXUP:=libtool
 PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
@@ -47,6 +50,8 @@ define Package/xserver-kdrive/Default
   +pixman \
   +libopenssl \
   +libdrm \
+  +xkbcomp \
+  +xkbdata \
   @DISPLAY_SUPPORT \
   +X_TSLIB:tslib
 endef
@@ -119,6 +124,7 @@ define Build/Configure
                --disable-secure-rpc \
                --enable-silent-rules \
                --disable-shave \
+               --disable-xsdl \
        )
 endef