[packages] xorg-kdrive: Add missing dependencies and 600x800 mode
[openwrt/svn-archive/archive.git] / Xorg / xorg / xserver / xorg-server / Makefile
index e618a5873d2aea02ee2190081ad24ebecd159d3b..41a9a808b6494b65ff7f617293f442ae7162a110 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,10 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=xorg-server
-PKG_RELEASE:=1
 PKG_VERSION:=1.7.1
+PKG_RELEASE:=1
+
 PKG_SOURCE_URL:=http://xorg.freedesktop.org/releases/individual/xserver/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_MD5SUM:=dda7842467cda6018fdc87e6002e4db1
+
 PKG_BUILD_DIR:=$(BUILD_DIR)/Xorg/xserver/$(PKG_NAME)-$(PKG_VERSION)/
 PKG_BUILD_DEPENDS:=randrproto renderproto fixesproto damageproto xcmiscproto \
                                   xextproto xproto scrnsaverproto bigreqsproto resourceproto \
@@ -21,6 +24,8 @@ PKG_BUILD_DEPENDS:=randrproto renderproto fixesproto damageproto xcmiscproto \
 PKG_INSTALL:=1
 PKG_FIXUP:=libtool
 
+PKG_CONFIG_DEPENDS:=CONFIG_PACKAGE_xserver-xorg CONFIG_PACKAGE_xserver-common
+
 include $(INCLUDE_DIR)/package.mk
 
 X_CONFIG=generic
@@ -45,6 +50,7 @@ $(call Package/xorg/Default)
   TITLE:=Xorg xserver
   DEPENDS:=+xserver-common \
   +libpthread \
+  +xkbcomp \
   +libxkbfile \
   +libXfont \
   +libXau \
@@ -58,12 +64,6 @@ $(call Package/xorg/Default)
   @DISPLAY_SUPPORT
 endef
 
-define Package/xserver-xorg-config
-$(call Package/xorg/Default)
-  TITLE:=Xorg server configuration tools
-  DEPENDS:=xserver-xorg
-endef
-
 define Package/xserver-common
 $(call Package/xorg/Default)
   TITLE:=meta-package