Fix astdb handling (#1295)
[openwrt/svn-archive/archive.git] / admin / gkrellmd / Makefile
index 41462b1ab1024cc8fd788fd98026b0140c3937ba..1153b2743df5680ba6e8164b6d1b70cf1ad34c98 100644 (file)
@@ -1,3 +1,11 @@
+#
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: $
+
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gkrellmd
@@ -37,11 +45,9 @@ endef
 
 define Package/gkrellmd/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_BUILD_DIR)/server/$(PKG_NAME) $(1)/usr/bin/
-
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/server/$(PKG_NAME) $(1)/usr/bin/
        $(INSTALL_DIR) $(1)/etc
-       $(CP) $(PKG_BUILD_DIR)/server/$(PKG_NAME).conf $(1)/etc/
-
+       $(INSTALL_CONF) $(PKG_BUILD_DIR)/server/$(PKG_NAME).conf $(1)/etc/
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/gkrellmd.init $(1)/etc/init.d/gkrellmd
 endef