fix cflags in gkrellmd
[openwrt/svn-archive/archive.git] / admin / gkrellmd / Makefile
index 1153b2743df5680ba6e8164b6d1b70cf1ad34c98..1943c0fab26fbcd81f765489280dd62d8f05c2ae 100644 (file)
@@ -4,7 +4,7 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
+# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -30,15 +30,12 @@ define Package/gkrellmd
   URL:=http://gkrellm.net/
 endef
 
-define Build/Configure
-endef
-
 define Build/Compile
-       CFLAGS="$(TARGET_CFLAGS) $(EXTRA_CPPFLAGS) "
-       LDFLAGS="$(EXTRA_LDFLAGS) "
+       CFLAGS="$(TARGET_CFLAGS) $(EXTRA_CPPFLAGS)" \
+       LDFLAGS="$(EXTRA_LDFLAGS) " \
        $(MAKE) -C $(PKG_BUILD_DIR)/server \
-               CC=$(TARGET_CC) \
-               glib12=yes \
+               CC="$(TARGET_CC)" \
+               glib12="yes" \
                GLIB12_LIB="-L$(STAGING_DIR)/usr/lib -lglib -lgmodule" \
                GLIB12_INCLUDE="-I$(STAGING_DIR)/usr/include/glib-1.2 -I$(STAGING_DIR)/usr/lib/glib/include"
 endef