portmap:
[openwrt/svn-archive/archive.git] / admin / htop / Makefile
index ce9f20537b25f750c6bb49784a29e9122ce2bb00..3c90dfe864e83cb7125582f7b290bf708802b117 100644 (file)
@@ -4,21 +4,17 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
+# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=htop
 PKG_VERSION:=0.6.5
 PKG_RELEASE:=1
-PKG_MD5SUM:=180aa7c9db7106ed1197b1e408660a0e
 
-PKG_SOURCE_URL:=@SF/htop
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_SOURCE_URL:=@SF/htop
+PKG_MD5SUM:=180aa7c9db7106ed1197b1e408660a0e
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -27,22 +23,20 @@ define Package/htop
   CATEGORY:=Administration
   TITLE:=process viewer
   DEPENDS:=+libncurses
-  DESCRIPTION:=\
-       An interactive process viewer with colors \\\
-       tree mode and other features.
   URL:=http://htop.sourceforge.net/
 endef
 
+define Package/htop/description
+ An interactive process viewer with colors tree mode and other features.
+endef
+
 define Build/Compile
-       mkdir -p $(PKG_INSTALL_DIR)
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
+       $(MAKE) -C $(PKG_BUILD_DIR) all
 endef
 
 define Package/htop/install    
        $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/htop $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/htop $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,htop))