[packages_10.03.1] collectd: backport r29404
[openwrt/svn-archive/archive.git] / admin / htop / Makefile
index 1bda9897aeef2c079fc718905776dce4d2c9e8b2..9a33d11479cea1a3c2071b6a4cfb8fd158d469e4 100644 (file)
@@ -1,42 +1,48 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=htop
-PKG_VERSION:=0.6.6
+PKG_VERSION:=0.9
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@SF/htop
-PKG_MD5SUM:=12c8e6e97bd50a4e0a4730d23675fc7b
+PKG_SOURCE_URL:=@SF/$(PKG_NAME)
+PKG_MD5SUM:=7c5507f35f363f3f40183a2ba3c561f8
+
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/htop
   SECTION:=admin
   CATEGORY:=Administration
-  TITLE:=process viewer
+  TITLE:=Interactive processes viewer
   DEPENDS:=+libncurses
   URL:=http://htop.sourceforge.net/
 endef
 
 define Package/htop/description
-       An interactive process viewer with colors tree mode and other features.
+ Htop is an ncursed-based process viewer similar to top, but
+ it allows to scroll the list vertically and horizontally to
+ see all processes and their full command lines.
 endef
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) all
-endef
+CONFIGURE_VARS += \
+       ac_cv_file__proc_stat=yes \
+       ac_cv_file__proc_meminfo=yes \
+       ac_cv_func_malloc_0_nonnull=yes \
+       ac_cv_func_realloc_0_nonnull=yes
 
-define Package/htop/install    
+define Package/htop/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/htop $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/$(PKG_NAME) $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,htop))