[package] update xtables-addons to 1.7 (#5369)
[openwrt/svn-archive/archive.git] / admin / htop / Makefile
index 3c90dfe864e83cb7125582f7b290bf708802b117..b201de8a781b92624e51c1cdc274b45a54f9c30c 100644 (file)
@@ -1,42 +1,43 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=htop
-PKG_VERSION:=0.6.5
+PKG_VERSION:=0.8.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@SF/htop
-PKG_MD5SUM:=180aa7c9db7106ed1197b1e408660a0e
+PKG_SOURCE_URL:=@SF/$(PKG_NAME)
+PKG_MD5SUM:=f0b259ca29175656de48bf0fa0a2e619
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/htop
   SECTION:=admin
   CATEGORY:=Administration
-  TITLE:=process viewer
+  TITLE:=Interactive processes viewer
   DEPENDS:=+libncurses
   URL:=http://htop.sourceforge.net/
 endef
 
 define Package/htop/description
- An interactive process viewer with colors tree mode and other features.
+ Htop is an ncursed-based process viewer similar to top, but
+ it allows to scroll the list vertically and horizontally to
+ see all processes and their full command lines. 
 endef
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) all
-endef
+CONFIGURE_VARS += \
+       ac_cv_file__proc_stat=yes \
+       ac_cv_file__proc_meminfo=yes \
 
-define Package/htop/install    
+define Package/htop/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/htop $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,htop))