[packages] ucarp: update to 1.5.2, add missing libpcap depends, select the ip addr...
[openwrt/svn-archive/archive.git] / admin / osiris / Makefile
index d3037e948bd8f3ff5d716fb93fb832d1b1df0098..6b75bed3df0aeec7edb3e7e644de0a791468cb72 100644 (file)
@@ -1,24 +1,22 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=osiris
 PKG_VERSION:=4.2.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://osiris.shmoo.com/data/
 PKG_MD5SUM:=1951c7dc0fe729af9ffaf58910340d12
-PKG_CAT:=zcat
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_FIXUP:=libtool
+PKG_LIBTOOL_PATHS:=src/db-4.2.52/build_unix
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -30,26 +28,20 @@ define Package/osirisd
   URL:=http://www.hostintegrity.com/osiris
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --with-osiris-user=root \
-               --with-root-dir=/var/lib/osiris \
-               --with-readline=no, \
-               ac_cv_openssldir="$(STAGING_DIR)/usr" \
-       )
-endef
+CONFIGURE_ARGS += \
+       --with-osiris-user=root \
+       --with-root-dir=/var/lib/osiris \
+       --with-readline=no, \
+       ac_cv_openssldir="$(STAGING_DIR)/usr"
 
-define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               $(TARGET_CONFIGURE_OPTS) \
+MAKE_FLAGS += \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                INTERACTIVE=0 \
                all install
-endef
 
-define Package/osirisd/install 
+define Package/osirisd/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/osirisd $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/osirisd $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/osirisd.init $(1)/etc/init.d/osirisd
 endef