glib2 now needs the dev package from glib 2.0 installed on the host,
[openwrt/svn-archive/archive.git] / admin / osiris / Makefile
index 51ad2431a6fcb0f85a688e75d672805372a3bb99..73da8e6101241cc5173c00470e4ea093f91c67a0 100644 (file)
@@ -25,27 +25,21 @@ include $(INCLUDE_DIR)/package.mk
 define Package/osirisd
   SECTION:=admin
   CATEGORY:=Administration
-  DEPENDS:=+libopenssl
+  DEPENDS:=+libopenssl +libpthread
   TITLE:=Host integrity monitoring system (scanning agent)
   URL:=http://www.hostintegrity.com/osiris
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --with-osiris-user=root \
-               --with-root-dir=/var/lib/osiris \
-               --with-readline=no, \
-               ac_cv_openssldir="$(STAGING_DIR)/usr" \
-       )
-endef
+CONFIGURE_ARGS += \
+       --with-osiris-user=root \
+       --with-root-dir=/var/lib/osiris \
+       --with-readline=no, \
+       ac_cv_openssldir="$(STAGING_DIR)/usr"
 
-define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               $(TARGET_CONFIGURE_OPTS) \
+MAKE_FLAGS += \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                INTERACTIVE=0 \
                all install
-endef
 
 define Package/osirisd/install 
        $(INSTALL_DIR) $(1)/usr/sbin