[PATCH] bump kismet to 2009-06-R1
[openwrt/svn-archive/archive.git] / admin / sudo / Makefile
index 1a983b1afa512a7e97eecd6227cece4d97d38d18..3ef534bd2e6df5028e18640b8c37ae17788da222 100644 (file)
@@ -7,18 +7,18 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=sudo
-PKG_VERSION:=1.7.0
+PKG_VERSION:=1.7.2
 PKG_RELEASE:=1
 
-PKG_SOURCE:=sudo-$(PKG_VERSION).tar.gz
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.sudo.ws/sudo/dist/
-PKG_MD5SUM:=5fd96bba35fe29b464f7aa6ad255f0a6
+PKG_MD5SUM:=9caba8719c3e0f163880a05f02a48249
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/sudo
   SECTION:= admin
-  CATEGORY:=Admistration
+  CATEGORY:=Administration
   TITLE:=delegate authority to run commands
   URL:=http://www.sudo.ws/
 endef
@@ -27,15 +27,17 @@ define Package/sudo/description
   Sudo (su "do") allows a system administrator to delegate authority to give
   certain users (or groups of users) the ability to run some (or all) commands
   as root or another user while providing an audit trail of the commands and
-  their arguments. 
+  their arguments.
 endef
 
 CONFIGURE_ARGS+= \
        --without-pam \
        --disable-pam-session \
+       --with-editor=/bin/vi \
 
 CONFIGURE_VARS+= \
        sudo_cv_uid_t_len=10 \
+       sudo_cv_func_unsetenv_void=no \
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \