wshaper: fix install path
[openwrt/svn-archive/archive.git] / admin / zabbix / Makefile
index e0bdda00279a53bd7b0e4ff443203486118862c1..66dca10f01373ae0c557f6d3dd65736c441820ab 100644 (file)
@@ -11,13 +11,10 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=zabbix
 PKG_VERSION:=1.3.2
 PKG_RELEASE:=1
+PKG_MD5SUM:=698a07f4e53820e44ef4a72c7c191e92
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://kent.dl.sourceforge.net/sourceforge/zabbix/
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_SOURCE_URL:=@SF/zabbix
 
 PKG_BUILD_DEPENDS:=libsqlite3
 
@@ -27,10 +24,6 @@ define Package/zabbix/Default
   SECTION:=admin
   CATEGORY:=Administration
   TITLE:=Zabbix
-  DESCRIPTION:=\
-       ZABBIX is an enterprise-class distributed monitoring solution for networks \\\
-       and applications. Native high-performance ZABBIX agents allow monitoring of \\\
-       performance and availability data of all operating systems.
   URL:=http://www.zabbix.com/
   SUBMENU:=zabbix
 endef
@@ -84,14 +77,14 @@ endef
 
 define Package/zabbix-agent/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/zabbix_agentd $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/zabbix_agentd $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc/zabbix
        $(INSTALL_CONF) $(PKG_BUILD_DIR)/misc/conf/zabbix_agentd.conf $(1)/etc/zabbix/
 endef
 
 define Package/zabbix-sender/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/zabbix_sender $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/zabbix_sender $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc/zabbix
 endef
 
@@ -101,7 +94,7 @@ endef
 
 define Package/zabbix-server/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/zabbix_server $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/zabbix_server $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc/zabbix
        $(INSTALL_CONF) $(PKG_BUILD_DIR)/misc/conf/zabbix_server.conf $(1)/etc/zabbix/
 endef