[package] ruby: fix path to libiconv
[openwrt/svn-archive/archive.git] / admin / zabbix / Makefile
index 41f23a8713821a3cf5988d903e2c77a94a0529c0..7fd99a5d2f54b7120808f9ce37232605ff165dac 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,10 +10,10 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=zabbix
 PKG_VERSION:=1.6
 PKG_RELEASE:=2
-PKG_MD5SUM:=39d4c871439b1b4f0429964b4abbfc45
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/zabbix
+PKG_MD5SUM:=39d4c871439b1b4f0429964b4abbfc45
 
 PKG_BUILD_DEPENDS:=libsqlite3
 PKG_INSTALL:=1
@@ -50,24 +50,18 @@ ifneq ($(SDK),)
 CONFIG_PACKAGE_zabbix-server:=m
 endif
 
-PKG_CONFIGURE_OPTIONS:= \
+CONFIGURE_ARGS+= \
        --bindir="/usr/sbin" \
        --enable-agent
 
 ifneq ($(CONFIG_PACKAGE_zabbix-server),)
-PKG_CONFIGURE_OPTIONS+= \
+  CONFIGURE_ARGS+= \
        --enable-server \
        --with-sqlite3="$(STAGING_DIR)/usr"
 endif
 
 MAKE_FLAGS += ARCH="linux"
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               $(PKG_CONFIGURE_OPTIONS) \
-       )
-endef
-
 define Package/zabbix-agent/conffiles
 /etc/zabbix/zabbix_agentd.conf
 endef
@@ -102,20 +96,20 @@ if [ -z "$${IPKG_INSTROOT}" ]; then
                        cp /rom/etc/passwd /etc/passwd
                fi
        fi
-fi
 
-echo ""
-if [ -z "$$(grep ^\\$${name}: $${IPKG_INSTROOT}/etc/group)" ]; then
-       echo "adding group $$name to /etc/group"
-       echo "$${name}:x:$${id}:" >> $${IPKG_INSTROOT}/etc/group
-fi
+       echo ""
+       if [ -z "$$(grep ^\\$${name}: $${IPKG_INSTROOT}/etc/group)" ]; then
+               echo "adding group $$name to /etc/group"
+               echo "$${name}:x:$${id}:" >> $${IPKG_INSTROOT}/etc/group
+       fi
 
-if [ -z "$$(grep ^\\$${name}: $${IPKG_INSTROOT}/etc/passwd)" ]; then
-       echo "adding user $$name to /etc/passwd"
-       echo "$${name}:x:$${id}:$${id}:$${name}:/tmp/.$${name}:/bin/false" >> $${IPKG_INSTROOT}/etc/passwd
-fi
+       if [ -z "$$(grep ^\\$${name}: $${IPKG_INSTROOT}/etc/passwd)" ]; then
+               echo "adding user $$name to /etc/passwd"
+               echo "$${name}:x:$${id}:$${id}:$${name}:/tmp/.$${name}:/bin/false" >> $${IPKG_INSTROOT}/etc/passwd
+       fi
 
-chown $${name} $${IPKG_INSTROOT}/etc/zabbix/zabbix_agentd.conf
+       chown $${name} $${IPKG_INSTROOT}/etc/zabbix/zabbix_agentd.conf
+fi
 
 endef