PATCH: upgrades kismet to 2007-10-R1
[openwrt/svn-archive/archive.git] / admin / zabbix / Makefile
index d77e12ed5a85459a1989d7418311c840ba19a1a3..9d54795b7512c921afe6fcd1ac832db0f1bb6d3e 100644 (file)
@@ -11,13 +11,10 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=zabbix
 PKG_VERSION:=1.3.2
 PKG_RELEASE:=1
+PKG_MD5SUM:=698a07f4e53820e44ef4a72c7c191e92
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://kent.dl.sourceforge.net/sourceforge/zabbix/
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_SOURCE_URL:=@SF/zabbix
 
 PKG_BUILD_DEPENDS:=libsqlite3
 
@@ -27,10 +24,6 @@ define Package/zabbix/Default
   SECTION:=admin
   CATEGORY:=Administration
   TITLE:=Zabbix
-  DESCRIPTION:=\
-       ZABBIX is an enterprise-class distributed monitoring solution for networks \\\
-       and applications. Native high-performance ZABBIX agents allow monitoring of \\\
-       performance and availability data of all operating systems.
   URL:=http://www.zabbix.com/
   SUBMENU:=zabbix
 endef
@@ -51,6 +44,11 @@ define Package/zabbix-server
   DEPENDS:=+libsqlite3
 endef
 
+
+ifneq ($(SDK),)
+CONFIG_PACKAGE_zabbix-server:=m
+endif
+
 PKG_CONFIGURE_OPTIONS:= \
        --bindir="/usr/sbin" \
        --enable-agent