add CVE-2009-1759 patch to ctorrent
[openwrt/svn-archive/archive.git] / devel / binutils / Makefile
index 318d387831b3b6837f04d0f09876771437effa81..64da1722aaf584e18658c45213882ba37c33dc9b 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,14 +9,26 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=binutils
 PKG_VERSION:=$(strip $(subst ",, $(CONFIG_BINUTILS_VERSION)))
 #"))
-PKG_RELEASE:=2
+PKG_RELEASE:=3
+
 PKG_SOURCE_URL:=@GNU/binutils
 PKG_SOURCE:=binutils-$(PKG_VERSION).tar.bz2
+PKG_MD5SUM:=
+
 PATCH_DIR:=$(TOPDIR)/toolchain/binutils/patches/$(PKG_VERSION)
+
+PKG_FIXUP:=libtool
+PKG_LIBTOOL_PATHS:=. gas bfd opcodes gprof binutils ld
 PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
+define Package/libbfd
+  SECTION:=devel
+  CATEGORY:=Development
+  TITLE:=libbfd
+endef
+
 define Package/binutils
   SECTION:=devel
   CATEGORY:=Development
@@ -28,20 +40,41 @@ define Package/objdump
   SECTION:=devel
   CATEGORY:=Development
   TITLE:=objdump
-  DEPENDS:=+zlib
+  DEPENDS:=+zlib +libbfd
 endef
 
 define Package/binutils/description
   The Binutils package contains a linker, an assembler, and other tools for handling object files
 endef
 
+CONFIGURE_ARGS = \
+               --target=$(REAL_GNU_TARGET_NAME) \
+               --host=$(REAL_GNU_TARGET_NAME) \
+               --build=$(GNU_HOST_NAME) \
+               --with-sysroot=$(PKG_INSTALL_DIR) \
+               --prefix=/usr \
+               --disable-multilib \
+               --disable-werror \
+               --disable-nls \
+               $(SOFT_FLOAT_CONFIG_OPTION) \
+               $(call qstrip,$(CONFIG_EXTRA_BINUTILS_CONFIG_OPTIONS))
+
 TARGET_CFLAGS += $(FPIC)
 
 define Build/Configure
-       $(call Build/Configure/Default, \
-               --disable-werror \
-               --disable-nls \
+       $(call Build/Configure/Default)
+       $(call Build/Compile/Default, \
+               configure-bfd \
+               configure-binutils \
+               configure-etc \
+               configure-gas \
+               configure-gprof \
+               configure-intl \
+               configure-ld \
+               configure-libiberty \
+               configure-opcodes \
        )
+       $(MAKE) -C $(PKG_BUILD_DIR)/bfd/po Makefile
 endef
 
 define Build/InstallDev
@@ -55,6 +88,7 @@ define Build/InstallDev
        $(CP) \
                $(PKG_INSTALL_DIR)/usr/include/* \
                $(1)/usr/include/
+       rm -f $(1)/usr/include/gdbm.h
 endef
 
 define Build/Compile
@@ -62,17 +96,26 @@ define Build/Compile
        $(call Build/Compile/Default)
 endef
 
+define Package/libbfd/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/libopcodes-$(PKG_VERSION).so \
+               $(PKG_INSTALL_DIR)/usr/lib/libbfd-$(PKG_VERSION).so \
+               $(1)/usr/lib/
+endef
+
 define Package/objdump/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/*-linux/bin/objdump $(1)/usr/bin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/$(REAL_GNU_TARGET_NAME)/bin/objdump $(1)/usr/bin/
 endef
 
 define Package/binutils/install
        $(INSTALL_DIR) $(1)/usr
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/ $(1)/usr/
-       $(CP) $(PKG_INSTALL_DIR)/usr/*-linux $(1)/usr
+       $(CP) $(PKG_INSTALL_DIR)/usr/$(REAL_GNU_TARGET_NAME) $(1)/usr
        rm -f $(1)/usr/bin/objdump
 endef
 
+$(eval $(call BuildPackage,libbfd))
 $(eval $(call BuildPackage,binutils))
 $(eval $(call BuildPackage,objdump))