binutils: do not overwrite gdbm.h
[openwrt/svn-archive/archive.git] / devel / binutils / Makefile
index da30a3ca0c171edea7da0dc7ed4da8a189c9980e..9491d7f3d78ca51b06b8c718c8e902f866794ae5 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,14 +9,8 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=binutils
 PKG_VERSION:=$(strip $(subst ",, $(CONFIG_BINUTILS_VERSION)))
 #"))
-PKG_RELEASE:=1
-PKG_SOURCE_URL:=http://ftp.gnu.org/gnu/binutils/ \
-       ftp://gatekeeper.dec.com/pub/GNU/ \
-               ftp://ftp.uu.net/archive/systems/gnu/ \
-               ftp://ftp.eu.uu.net/pub/gnu/ \
-               ftp://ftp.funet.fi/pub/gnu/prep/ \
-               ftp://ftp.leo.org/pub/comp/os/unix/gnu/
-
+PKG_RELEASE:=2
+PKG_SOURCE_URL:=@GNU/binutils
 PKG_SOURCE:=binutils-$(PKG_VERSION).tar.bz2
 PATCH_DIR:=$(TOPDIR)/toolchain/binutils/patches/$(PKG_VERSION)
 PKG_INSTALL:=1
@@ -41,11 +35,7 @@ define Package/binutils/description
   The Binutils package contains a linker, an assembler, and other tools for handling object files
 endef
 
-define Package/libbfd
-  SECTION:=libs
-  CATEGORY:=Libraries
-  TITLE:=libbfd
-endef
+TARGET_CFLAGS += $(FPIC)
 
 define Build/Configure
        $(call Build/Configure/Default, \
@@ -65,6 +55,7 @@ define Build/InstallDev
        $(CP) \
                $(PKG_INSTALL_DIR)/usr/include/* \
                $(1)/usr/include/
+       rm -f $(1)/usr/include/gdbm.h
 endef
 
 define Build/Compile
@@ -84,10 +75,5 @@ define Package/binutils/install
        rm -f $(1)/usr/bin/objdump
 endef
 
-define Package/libbdf/install
-    true
-endef
-
 $(eval $(call BuildPackage,binutils))
 $(eval $(call BuildPackage,objdump))
-$(eval $(call BuildPackage,libbfd))