make use of the new PKG_HOST_ONLY variable in boost-jam
[openwrt/svn-archive/archive.git] / devel / boost-jam / Makefile
index 98137b3a36951e446e72809af0f00a5bbdb79aff..e9a1376f29a710fbec4fdc5751083c2afefa7e69 100644 (file)
@@ -14,8 +14,7 @@ PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=@SF/boost
-
-BUILDONLY:=1
+PKG_HOST_ONLY:=1
 
 include $(INCLUDE_DIR)/host-build.mk
 include $(INCLUDE_DIR)/package.mk
@@ -24,12 +23,10 @@ define Package/boost-jam
   SECTION:=devel
   CATEGORY:=Development
   TITLE:=Boost JAM
+  BUILDONLY:=1
   URL:=http://www.boost.org
 endef
 
-define Build/DefaultTargets
-endef
-
 define Host/Compile
        # bjam does not provide a configure-script nor a Makefile
        ( cd $(HOST_BUILD_DIR) ; ./build.sh gcc )