[packages] diffutils: update to 3.0, use PKG_INSTALL, handle the busybox diff applet...
[openwrt/svn-archive/archive.git] / devel / diffutils / Makefile
index 319e81c63143732b0b20c27be0a5f535f69a92e4..202cc099c0375a49a02aedcdd6464f704f09fd4a 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,11 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=diffutils
-PKG_VERSION:=2.8.1
+PKG_VERSION:=3.0
 PKG_RELEASE:=1
-PKG_MD5SUM:=71f9c5ae19b60608f6c7f162da86a428
-PKG_SOURCE_URL:=http://ftp.gnu.org/gnu/diffutils/
+
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@GNU/diffutils
+PKG_MD5SUM:=684aaba1baab743a2a90e52162ff07da
+
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -20,24 +23,34 @@ define Package/diffutils
   SECTION:=devel
   CATEGORY:=Development
   TITLE:=diffutils
-  URL:=http://www.gnu.org/
+  URL:=http://www.gnu.org/software/diffutils/
 endef
 
 define Package/diffutils/description
-  The Diffutils package contains programs that show the differences between files or directories.
+  The Diffutils package contains programs that show the differences between
+  files or directories.
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default,ac_cv_func_mempcpy=n)
+CONFIGURE_VARS += \
+       ac_cv_func_mempcpy=n \
+
+define Package/diffutils/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/{sdiff,diff3,diff,cmp} $(1)/usr/bin/
 endef
 
-define Build/Compile
-       $(MAKE_VARS) $(MAKE) $(MAKE_ARGS) -C $(PKG_BUILD_DIR) all
+define Package/diffutils/preinst
+#!/bin/sh
+if [ -e $${IPKG_INSTROOT}/usr/bin/diff ]; then
+  rm $${IPKG_INSTROOT}/usr/bin/diff;
+fi
 endef
 
-define Package/diffutils/install
-       $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/{sdiff,diff3,diff,cmp} $(1)/usr/bin/
+define Package/diffutils/postrm
+#!/bin/sh
+ln -sf ../../bin/busybox $${IPKG_INSTROOT}/usr/bin/diff
+$${IPKG_INSTROOT}/usr/bin/diff 2>&1 | grep 'applet not found' > /dev/null 2>&1 && rm $${IPKG_INSTROOT}/usr/bin/diff
+exit 0
 endef
 
 $(eval $(call BuildPackage,diffutils))