postgresql: Parallel build fixes
[openwrt/svn-archive/archive.git] / devel / patch / Makefile
index 19a68ca34a16cb85e6c4185ec1df185f2b8a6422..fa3f14a2840f6508b175b7491e601e2b76bca7f4 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,11 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=patch
-PKG_VERSION:=2.5.4
+PKG_VERSION:=2.5.9
 PKG_RELEASE:=1
-PKG_MD5SUM:=ee5ae84d115f051d87fcaaef3b4ae782
-PKG_SOURCE_URL:=http://ftp.gnu.org/gnu/patch/
+
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@GNU/patch
+PKG_MD5SUM:=dacfb618082f8d3a2194601193cf8716
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -24,20 +25,19 @@ define Package/patch
 endef
 
 define Package/patch/description
-  The Patch package contains a program for modifying or creating files by applying a "patch" file typically created by the diff program.
-endef
-
-define Build/Configure
-       $(call Build/Configure/Default)
+  The Patch package contains a program for modifying or creating files 
+  by applying a "patch" file typically created by the diff program.
 endef
 
 define Build/Compile
-       $(MAKE_VARS) $(MAKE) $(MAKE_ARGS) DESTDIR=$(PKG_INSTALL_DIR) exec_prefix=$(PKG_INSTALL_DIR) -C $(PKG_BUILD_DIR) all install 
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               exec_prefix="$(PKG_INSTALL_DIR)" \
+               all install 
 endef
 
 define Package/patch/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/bin/patch $(1)/usr/bin/
+       $(CP) $(PKG_INSTALL_DIR)/bin/patch $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,patch))