Fix docs build from a clean checkout, closes #2975
[openwrt/svn-archive/archive.git] / docs / Makefile
index ffc5bbb062a331f799c9135a1872ced603f3e49b..cdaf09c1e04ffdb09afb9d38d6f477c1ab1e3377 100644 (file)
@@ -17,6 +17,7 @@ compile:
        $(NO_TRACE_MAKE) cleanup
 
 $(TMP_DIR)/.prereq-docs:
+       mkdir -p $(TMP_DIR)
        $(NO_TRACE_MAKE) prereq
        touch $@
 
@@ -25,13 +26,16 @@ openwrt.html: $(DEPS)
 
 openwrt.pdf: $(DEPS)
        pdflatex $(MAIN)
-       
+
 clean: cleanup
        rm -f openwrt.pdf openwrt.html openwrt.css
 
 cleanup: FORCE
        rm -f *.log *.aux *.toc *.out *.lg *.dvi *.idv *.4ct *.4tc *.xref *.tmp *.dvi
 
+$(eval $(call RequireCommand,latex, \
+       You need to install LaTeX to build the OpenWrt documentation \
+))
 $(eval $(call RequireCommand,pdflatex, \
        You need to install LaTeX to build the OpenWrt documentation \
 ))