remove unnecessary deps
[openwrt/svn-archive/archive.git] / docs / Makefile
index 9e888a4af2df7fab545631ffe872b16106738ffb..ffc5bbb062a331f799c9135a1872ced603f3e49b 100644 (file)
@@ -2,20 +2,22 @@ ifeq ($(TOPDIR),)
   TOPDIR:=${CURDIR}/..
 endif
 
+all: compile
+
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/prereq.mk
 
 MAIN = openwrt.tex
-DEPS = $(MAIN) Makefile config.tex network.tex network-scripts.tex network-scripts.tex wireless.tex build.tex adding.tex bugs.tex .prereq
+DEPS = $(MAIN) Makefile config.tex network.tex network-scripts.tex network-scripts.tex wireless.tex build.tex adding.tex bugs.tex $(TMP_DIR)/.prereq-docs
 
-all:
-       $(MAKE) cleanup
+compile:
+       $(NO_TRACE_MAKE) cleanup
        latex $(MAIN)
-       $(MAKE) openwrt.pdf openwrt.html
-       $(MAKE) cleanup
+       $(NO_TRACE_MAKE) openwrt.pdf openwrt.html
+       $(NO_TRACE_MAKE) cleanup
 
-.prereq:
-       $(MAKE) prereq
+$(TMP_DIR)/.prereq-docs:
+       $(NO_TRACE_MAKE) prereq
        touch $@
 
 openwrt.html: $(DEPS)