kernel: modules names changed with kernel 2.6.35
[openwrt/svn-archive/archive.git] / docs / build.tex
index 493be127c6f485bbe18561757b229b3b57515e76..6828a23183563d5a192bca9febd2904caa1b8ace 100644 (file)
@@ -45,7 +45,7 @@ This article refers to the "Kamikaze" branch of OpenWrt, which can be downloaded
 subversion using the following command:
 
 \begin{Verbatim}
-$ svn checkout https://svn.openwrt.org/openwrt/trunk kamikaze
+$ svn checkout svn://svn.openwrt.org/openwrt/trunk kamikaze
 \end{Verbatim}
 
 Additionally, there is a trac interface on \href{https://dev.openwrt.org/}{https://dev.openwrt.org/}
@@ -182,7 +182,7 @@ and packages will be in the "\texttt{bin/packages}" directory.
 
 One of the things that we've attempted to do with OpenWrt's template system is make it
 incredibly easy to port software to OpenWrt. If you look at a typical package directory
-in OpenWrt you'll find two things:
+in OpenWrt you'll find several things:
 
 \begin{itemize}
     \item \texttt{package/\textit{<name>}/Makefile}
@@ -204,7 +204,6 @@ simplifies the entire ordeal.
 Here for example, is \texttt{package/bridge/Makefile}:
 
 \begin{Verbatim}[frame=single,numbers=left]
-# $Id: Makefile 5624 2006-11-23 00:29:07Z nbd $
 
 include $(TOPDIR)/rules.mk
 
@@ -294,7 +293,7 @@ directly as the Nth argument to \texttt{BuildPackage}.
 
     \begin{itemize}
         \item \texttt{SECTION} \\
-            The type of package (currently unused)
+            The section of package (currently unused)
         \item \texttt{CATEGORY} \\
             Which menu it appears in menuconfig: Network, Sound, Utilities, Multimedia ...
         \item \texttt{TITLE} \\
@@ -394,7 +393,6 @@ To do so, you can use the following template, which basically sets to nothing th
 Compile templates.
 
 \begin{Verbatim}[frame=single,numbers=left]
-# $Id: $
 
 include $(TOPDIR)/rules.mk
 
@@ -451,7 +449,6 @@ For external kernel modules, you can add them to the build system just like if t
 Here for instance the Makefile for the I2C subsytem kernel modules :
 
 \begin{Verbatim}[frame=single,numbers=left]
-# $Id $
 
 I2CMENU:=I2C Bus