[include] autotools.mk: if ./autogen.sh exists, call that. Call autoreconfig only...
[openwrt/svn-archive/archive.git] / include / autotools.mk
index a2d57d6971bcb7ab5b184a49def37cfea66158ce..32036046824620d5d7fd6ca25b10115c1ad66d54 100644 (file)
@@ -23,7 +23,14 @@ define libtool_remove_files
 endef
 
 define autoreconf
-       (cd $(PKG_BUILD_DIR); $(STAGING_DIR_HOST)/bin/autoreconf -v -f -i -s $(patsubst %,-I %,$(PKG_LIBTOOL_PATHS)) $(PKG_LIBTOOL_PATHS));
+       (cd $(PKG_BUILD_DIR); \
+               if [ -x ./autogen.sh ]; then \
+                       ./autogen.sh; \
+               elif [ -f ./configure.ac ] || [ -f ./configure.in ]; then \
+                       $(STAGING_DIR_HOST)/bin/autoreconf -v -f -i -s \
+                               $(patsubst %,-I %,$(PKG_LIBTOOL_PATHS)) $(PKG_LIBTOOL_PATHS); \
+               fi \
+       );
 endef
 
 Hooks/InstallDev/Post += libtool_remove_files