[include] autotools.mk: support autoreconf at different paths, introduce PKG_AUTOMAKE...
[openwrt/svn-archive/archive.git] / include / autotools.mk
index 32036046824620d5d7fd6ca25b10115c1ad66d54..4a7c10bf8611c56440b38ec16d79a4985fee8f83 100644 (file)
@@ -6,16 +6,11 @@
 #
 
 PKG_LIBTOOL_PATHS?=$(CONFIGURE_PATH)
+PKG_AUTOMAKE_PATHS?=$(CONFIGURE_PATH)
+PKG_REMOVE_FILES?=aclocal.m4
 
 autoconf_bool = $(patsubst %,$(if $($(1)),--enable,--disable)-%,$(2))
 
-# prevent libtool from linking against host development libraries
-define libtool_fixup_libdir
-       find $(1) -name '*.la' | $(XARGS) \
-               $(SED) "s,\(^libdir='\| \|-L\|^dependency_libs='\)/usr/lib,\1$(STAGING_DIR)/usr/lib,g" \
-                   -e "s,$(STAGING_DIR)/usr/lib/\(libstdc++\|libsupc++\).la,$(TOOLCHAIN_DIR)/lib/\1.la,g";
-endef
-
 # delete *.la-files from staging_dir - we can not yet remove respective lines within all package
 # Makefiles, since backfire still uses libtool v1.5.x which (may) require those files
 define libtool_remove_files
@@ -24,12 +19,19 @@ endef
 
 define autoreconf
        (cd $(PKG_BUILD_DIR); \
-               if [ -x ./autogen.sh ]; then \
-                       ./autogen.sh; \
-               elif [ -f ./configure.ac ] || [ -f ./configure.in ]; then \
-                       $(STAGING_DIR_HOST)/bin/autoreconf -v -f -i -s \
-                               $(patsubst %,-I %,$(PKG_LIBTOOL_PATHS)) $(PKG_LIBTOOL_PATHS); \
-               fi \
+               $(patsubst %,rm -f %;,$(PKG_REMOVE_FILES)) \
+               $(foreach p,$(PKG_AUTOMAKE_PATHS), \
+                       if [ -x $(p)/autogen.sh ]; then \
+                               $(p)/autogen.sh || true; \
+                       elif [ -f $(p)/configure.ac ] || [ -f $(p)/configure.in ]; then \
+                               [ -f $(p)/aclocal.m4 ] && [ ! -f $(p)/acinclude.m4 ] && mv aclocal.m4 acinclude.m4; \
+                               [ -d $(p)/autom4te.cache ] && rm -rf autom4te.cache; \
+                               $(STAGING_DIR_HOST)/bin/autoreconf -v -f -i -s \
+                                       -B $(STAGING_DIR_HOST)/share/aclocal \
+                                       -B $(STAGING_DIR)/host/share/aclocal \
+                                       $(patsubst %,-I %,$(PKG_LIBTOOL_PATHS)) $(PKG_LIBTOOL_PATHS) || true; \
+                       fi; \
+               ) \
        );
 endef
 
@@ -37,13 +39,20 @@ Hooks/InstallDev/Post += libtool_remove_files
 
 ifneq ($(filter libtool,$(PKG_FIXUP)),)
   PKG_BUILD_DEPENDS += libtool
+ ifeq ($(filter no-autoreconf,$(PKG_FIXUP)),)
   Hooks/Configure/Pre += autoreconf
-  Hooks/InstallDev/Post += libtool_fixup_libdir
+ endif
 endif
  
 ifneq ($(filter libtool-ucxx,$(PKG_FIXUP)),)
   PKG_BUILD_DEPENDS += libtool
+ ifeq ($(filter no-autoreconf,$(PKG_FIXUP)),)
   Hooks/Configure/Pre += autoreconf
-  Hooks/InstallDev/Post += libtool_fixup_libdir
+ endif
 endif
 
+ifneq ($(filter autoreconf,$(PKG_FIXUP)),)
+  ifeq ($(filter autoreconf,$(Hooks/Configure/Pre)),)
+    Hooks/Configure/Pre += autoreconf
+  endif
+endif