[include] autotools.mk: disable autoreconf recursion if more than one dir is given...
[openwrt/svn-archive/archive.git] / include / autotools.mk
index 2851731ef3b3b5ac67514f5da7ef84c41dfc6b74..7fe376cc156b7e5401192288ab1be614e009f078 100644 (file)
@@ -38,9 +38,12 @@ define autoreconf
                                [ -d $(p)/autom4te.cache ] && rm -rf autom4te.cache; \
                                touch NEWS AUTHORS COPYING ChangeLog; \
                                $(AM_TOOL_PATHS) $(STAGING_DIR_HOST)/bin/autoreconf -v -f -i -s \
                                [ -d $(p)/autom4te.cache ] && rm -rf autom4te.cache; \
                                touch NEWS AUTHORS COPYING ChangeLog; \
                                $(AM_TOOL_PATHS) $(STAGING_DIR_HOST)/bin/autoreconf -v -f -i -s \
+                                       $(if $(word 2,$(3)),--no-recursive) \
                                        -B $(STAGING_DIR_HOST)/share/aclocal \
                                        -B $(STAGING_DIR_HOST)/share/aclocal \
-                                       $(patsubst %,-B %,$(5)) \
+                                       $(patsubst %,-I %,$(5)) \
                                        $(patsubst %,-I %,$(4)) $(4) || true; \
                                        $(patsubst %,-I %,$(4)) $(4) || true; \
+                               [ -e $(p)/config.rpath ] || \
+                                               ln -s $(SCRIPT_DIR)/config.rpath $(p)/config.rpath;
                        fi; \
                ) \
        );
                        fi; \
                ) \
        );