[include] autotools.mk: allow disabling autoreconf, remove libdir fixup
[openwrt/svn-archive/archive.git] / include / autotools.mk
index a2d57d6971bcb7ab5b184a49def37cfea66158ce..9ba3fc33b9e901a1e8fe80ef18094c6cab0c2264 100644 (file)
@@ -9,13 +9,6 @@ PKG_LIBTOOL_PATHS?=$(CONFIGURE_PATH)
 
 autoconf_bool = $(patsubst %,$(if $($(1)),--enable,--disable)-%,$(2))
 
-# prevent libtool from linking against host development libraries
-define libtool_fixup_libdir
-       find $(1) -name '*.la' | $(XARGS) \
-               $(SED) "s,\(^libdir='\| \|-L\|^dependency_libs='\)/usr/lib,\1$(STAGING_DIR)/usr/lib,g" \
-                   -e "s,$(STAGING_DIR)/usr/lib/\(libstdc++\|libsupc++\).la,$(TOOLCHAIN_DIR)/lib/\1.la,g";
-endef
-
 # delete *.la-files from staging_dir - we can not yet remove respective lines within all package
 # Makefiles, since backfire still uses libtool v1.5.x which (may) require those files
 define libtool_remove_files
@@ -23,20 +16,29 @@ define libtool_remove_files
 endef
 
 define autoreconf
-       (cd $(PKG_BUILD_DIR); $(STAGING_DIR_HOST)/bin/autoreconf -v -f -i -s $(patsubst %,-I %,$(PKG_LIBTOOL_PATHS)) $(PKG_LIBTOOL_PATHS));
+       (cd $(PKG_BUILD_DIR); \
+               if [ -x ./autogen.sh ]; then \
+                       ./autogen.sh || true; \
+               elif [ -f ./configure.ac ] || [ -f ./configure.in ]; then \
+                       $(STAGING_DIR_HOST)/bin/autoreconf -v -f -i -s \
+                               $(patsubst %,-I %,$(PKG_LIBTOOL_PATHS)) $(PKG_LIBTOOL_PATHS) || true; \
+               fi \
+       );
 endef
 
 Hooks/InstallDev/Post += libtool_remove_files
 
 ifneq ($(filter libtool,$(PKG_FIXUP)),)
   PKG_BUILD_DEPENDS += libtool
+ ifeq ($(filter no-autoreconf,$(PKG_FIXUP)),)
   Hooks/Configure/Pre += autoreconf
-  Hooks/InstallDev/Post += libtool_fixup_libdir
+ endif
 endif
  
 ifneq ($(filter libtool-ucxx,$(PKG_FIXUP)),)
   PKG_BUILD_DEPENDS += libtool
+ ifeq ($(filter no-autoreconf,$(PKG_FIXUP)),)
   Hooks/Configure/Pre += autoreconf
-  Hooks/InstallDev/Post += libtool_fixup_libdir
+ endif
 endif