[include] autotools.mk: like libintl, make all libtool fixup packages depend on the...
[openwrt/svn-archive/archive.git] / include / autotools.mk
index 6923b018b9ac855db567a28e765df268a6023290..9bb984da7c6211093e0e6eb034dfe14eac064ca7 100644 (file)
@@ -61,14 +61,14 @@ define autoreconf_target
 endef
 
 ifneq ($(filter libtool,$(PKG_FIXUP)),)
-  PKG_BUILD_DEPENDS += libtool
+  PKG_BUILD_DEPENDS += libtool libintl libiconv
  ifeq ($(filter no-autoreconf,$(PKG_FIXUP)),)
   Hooks/Configure/Pre += autoreconf_target
  endif
 endif
 
 ifneq ($(filter libtool-ucxx,$(PKG_FIXUP)),)
-  PKG_BUILD_DEPENDS += libtool
+  PKG_BUILD_DEPENDS += libtool libintl libiconv
  ifeq ($(filter no-autoreconf,$(PKG_FIXUP)),)
   Hooks/Configure/Pre += autoreconf_target
  endif
@@ -93,14 +93,12 @@ define autoreconf_host
 endef
 
 ifneq ($(filter libtool,$(HOST_FIXUP)),)
-  HOST_BUILD_DEPENDS += libtool
  ifeq ($(filter no-autoreconf,$(HOST_FIXUP)),)
   Hooks/HostConfigure/Pre += autoreconf_host
  endif
 endif
 
 ifneq ($(filter libtool-ucxx,$(HOST_FIXUP)),)
-  HOST_BUILD_DEPENDS += libtool
  ifeq ($(filter no-autoreconf,$(HOST_FIXUP)),)
   Hooks/HostConfigure/Pre += autoreconf_host
  endif