[include] autotools.mk: like libintl, make all libtool fixup packages depend on the...
[openwrt/svn-archive/archive.git] / include / autotools.mk
index b4eb7bfc4e18104306a75229bf05fc2fa586fd70..9bb984da7c6211093e0e6eb034dfe14eac064ca7 100644 (file)
@@ -5,8 +5,6 @@
 # See /LICENSE for more information.
 #
 
-PKG_LIBTOOL_PATHS?=$(CONFIGURE_PATH)
-
 autoconf_bool = $(patsubst %,$(if $($(1)),--enable,--disable)-%,$(2))
 
 # delete *.la-files from staging_dir - we can not yet remove respective lines within all package
@@ -15,38 +13,99 @@ define libtool_remove_files
        find $(1) -name '*.la' | $(XARGS) rm -f;
 endef
 
+
+AM_TOOL_PATHS:= \
+       AUTOM4TE=$(STAGING_DIR_HOST)/bin/autom4te \
+       AUTOCONF=$(STAGING_DIR_HOST)/bin/autoconf \
+       AUTOMAKE=$(STAGING_DIR_HOST)/bin/automake \
+       ACLOCAL=$(STAGING_DIR_HOST)/bin/aclocal \
+       AUTOHEADER=$(STAGING_DIR_HOST)/bin/autoheader \
+       LIBTOOLIZE=$(STAGING_DIR_HOST)/bin/libtoolize \
+       M4=$(STAGING_DIR_HOST)/bin/m4 \
+       AUTOPOINT=true
+
+# 1: build dir
+# 2: remove files
+# 3: automake paths
+# 4: libtool paths
+# 5: extra m4 dirs
 define autoreconf
-       (cd $(PKG_BUILD_DIR); \
-               $(patsubst %,rm -f %;,$(PKG_REMOVE_FILES)) \
-               if [ -x ./autogen.sh ]; then \
-                       ./autogen.sh || true; \
-               elif [ -f ./configure.ac ] || [ -f ./configure.in ]; then \
-                       [ -f ./aclocal.m4 ] && [ ! -f ./acinclude.m4 ] && mv aclocal.m4 acinclude.m4; \
-                       $(STAGING_DIR_HOST)/bin/autoreconf -v -f -i -s \
-                               -B $(STAGING_DIR)/host/share/aclocal \
-                               $(patsubst %,-I %,$(PKG_LIBTOOL_PATHS)) $(PKG_LIBTOOL_PATHS) || true; \
-               fi \
+       (cd $(1); \
+               $(patsubst %,rm -f %;,$(2)) \
+               $(foreach p,$(3), \
+                       if [ -f $(p)/configure.ac ] || [ -f $(p)/configure.in ]; then \
+                               [ -f $(p)/aclocal.m4 ] && [ ! -f $(p)/acinclude.m4 ] && mv aclocal.m4 acinclude.m4; \
+                               [ -d $(p)/autom4te.cache ] && rm -rf autom4te.cache; \
+                               touch NEWS AUTHORS COPYING ChangeLog; \
+                               $(AM_TOOL_PATHS) $(STAGING_DIR_HOST)/bin/autoreconf -v -f -i -s \
+                                       -B $(STAGING_DIR_HOST)/share/aclocal \
+                                       $(patsubst %,-B %,$(5)) \
+                                       $(patsubst %,-I %,$(4)) -I m4 $(4) || true; \
+                       fi; \
+               ) \
        );
 endef
 
+
+PKG_LIBTOOL_PATHS?=$(CONFIGURE_PATH)
+PKG_AUTOMAKE_PATHS?=$(CONFIGURE_PATH)
+PKG_REMOVE_FILES?=aclocal.m4
+
 Hooks/InstallDev/Post += libtool_remove_files
 
+define autoreconf_target
+  $(strip $(call autoreconf, \
+    $(PKG_BUILD_DIR), $(PKG_REMOVE_FILES), \
+    $(PKG_AUTOMAKE_PATHS), $(PKG_LIBTOOL_PATHS), \
+    $(STAGING_DIR)/host/share/aclocal $(STAGING_DIR)/usr/share/aclocal))
+endef
+
 ifneq ($(filter libtool,$(PKG_FIXUP)),)
-  PKG_BUILD_DEPENDS += libtool
+  PKG_BUILD_DEPENDS += libtool libintl libiconv
  ifeq ($(filter no-autoreconf,$(PKG_FIXUP)),)
-  Hooks/Configure/Pre += autoreconf
+  Hooks/Configure/Pre += autoreconf_target
  endif
 endif
+
 ifneq ($(filter libtool-ucxx,$(PKG_FIXUP)),)
-  PKG_BUILD_DEPENDS += libtool
+  PKG_BUILD_DEPENDS += libtool libintl libiconv
  ifeq ($(filter no-autoreconf,$(PKG_FIXUP)),)
-  Hooks/Configure/Pre += autoreconf
+  Hooks/Configure/Pre += autoreconf_target
  endif
 endif
 
 ifneq ($(filter autoreconf,$(PKG_FIXUP)),)
   ifeq ($(filter autoreconf,$(Hooks/Configure/Pre)),)
-    Hooks/Configure/Pre += autoreconf
+    Hooks/Configure/Pre += autoreconf_target
+  endif
+endif
+
+
+HOST_FIXUP?=$(PKG_FIXUP)
+HOST_LIBTOOL_PATHS?=$(if $(PKG_LIBTOOL_PATHS),$(PKG_LIBTOOL_PATHS),.)
+HOST_AUTOMAKE_PATHS?=$(if $(PKG_AUTOMAKE_PATHS),$(PKG_AUTOMAKE_PATHS),.)
+HOST_REMOVE_FILES?=$(PKG_REMOVE_FILES)
+
+define autoreconf_host
+  $(strip $(call autoreconf, \
+    $(HOST_BUILD_DIR), $(HOST_REMOVE_FILES), \
+    $(HOST_AUTOMAKE_PATHS), $(HOST_LIBTOOL_PATHS)))
+endef
+
+ifneq ($(filter libtool,$(HOST_FIXUP)),)
+ ifeq ($(filter no-autoreconf,$(HOST_FIXUP)),)
+  Hooks/HostConfigure/Pre += autoreconf_host
+ endif
+endif
+
+ifneq ($(filter libtool-ucxx,$(HOST_FIXUP)),)
+ ifeq ($(filter no-autoreconf,$(HOST_FIXUP)),)
+  Hooks/HostConfigure/Pre += autoreconf_host
+ endif
+endif
+
+ifneq ($(filter autoreconf,$(HOST_FIXUP)),)
+  ifeq ($(filter autoreconf,$(Hooks/HostConfigure/Pre)),)
+    Hooks/HostConfigure/Pre += autoreconf_host
   endif
 endif