[include] autotools.mk: introduce PKG_REMOVE_FILES to delete certain files after...
[openwrt/svn-archive/archive.git] / include / autotools.mk
index f85026a944a496c67c9fa9a1f092d0a126e2c9fe..b236aace48b9c644845f77686a38633239d86f58 100644 (file)
@@ -5,63 +5,43 @@
 # See /LICENSE for more information.
 #
 
-define replace
-       if [ -f "$(PKG_BUILD_DIR)/$(3)$(1)" -a -e "$(2)/$(if $(4),$(4),$(1))" ]; then \
-               rm -f $(PKG_BUILD_DIR)/$(3)$(1); \
-               ln -s $(2)/$(if $(4),$(4),$(1)) $(PKG_BUILD_DIR)/$(3)$(1); \
-       fi
-       
-endef
-
 PKG_LIBTOOL_PATHS?=$(CONFIGURE_PATH)
 
-# replace copies of ltmain.sh with the build system's version
-update_libtool_common = \
-       $(foreach p,$(LIBTOOL_PATHS), \
-               $(call replace,ltmain.sh,$(STAGING_DIR)/host/share/libtool,$(p)/) \
-               $(call replace,libtool.m4,$(STAGING_DIR)/host/share/aclocal,$(p)/) \
-       )
-update_libtool = \
-       $(foreach p,$(PKG_LIBTOOL_PATHS), \
-               $(call replace,libtool,$(STAGING_DIR)/host/bin,$(p)/) \
-       ) \
-       $(call update_libtool_common)
-update_libtool_ucxx = \
-       $(foreach p,$(PKG_LIBTOOL_PATHS), \
-               $(call replace,libtool,$(STAGING_DIR)/host/bin,$(p)/,libtool-ucxx) \
-       ) \
-       $(call update_libtool_common)
-
+autoconf_bool = $(patsubst %,$(if $($(1)),--enable,--disable)-%,$(2))
 
-# prevent libtool from linking against host development libraries
-define libtool_fixup_libdir
-       find $(1) -name '*.la' | $(XARGS) \
-               $(SED) "s,\(^libdir='\| \|-L\|^dependency_libs='\)/usr/lib,\1$(STAGING_DIR)/usr/lib,g" \
-                   -e "s,$(STAGING_DIR)/usr/lib/\(libstdc++\|libsupc++\).la,$(TOOLCHAIN_DIR)/usr/lib/\1.la,g"
-       find $(2) -name '*.la' | $(XARGS) \
-               $(SED) "s,\(^libdir='\| \|-L\|^dependency_libs='\)/usr/lib,\1$(STAGING_DIR)/usr/lib,g" \
-                   -e "s,$(STAGING_DIR)/usr/lib/\(libstdc++\|libsupc++\).la,$(TOOLCHAIN_DIR)/usr/lib/\1.la,g"
+# delete *.la-files from staging_dir - we can not yet remove respective lines within all package
+# Makefiles, since backfire still uses libtool v1.5.x which (may) require those files
+define libtool_remove_files
+       find $(1) -name '*.la' | $(XARGS) rm -f;
 endef
 
-define remove_version_check
-       if [ -f "$(PKG_BUILD_DIR)/$(CONFIGURE_PATH)/configure" ]; then \
-               $(SED) \
-                       's,\(gentoo\|pardus\)_ltmain_version=.*,\1_ltmain_version="$$$$\1_lt_version",' \
-                       $(PKG_BUILD_DIR)/$(CONFIGURE_PATH)/configure; \
-       fi
+define autoreconf
+       (cd $(PKG_BUILD_DIR); \
+               $(patsubst %,rm -f %;,$(PKG_REMOVE_FILES)) \
+               if [ -x ./autogen.sh ]; then \
+                       ./autogen.sh || true; \
+               elif [ -f ./configure.ac ] || [ -f ./configure.in ]; then \
+                       [ -f ./aclocal.m4 ] && [ ! -f ./acinclude.m4 ] && mv aclocal.m4 acinclude.m4; \
+                       $(STAGING_DIR_HOST)/bin/autoreconf -v -f -i -s \
+                               -B $(STAGING_DIR)/host/share/aclocal \
+                               $(patsubst %,-I %,$(PKG_LIBTOOL_PATHS)) $(PKG_LIBTOOL_PATHS) || true; \
+               fi \
+       );
 endef
 
+Hooks/InstallDev/Post += libtool_remove_files
+
 ifneq ($(filter libtool,$(PKG_FIXUP)),)
   PKG_BUILD_DEPENDS += libtool
-  Hooks/Configure/Pre += update_libtool remove_version_check
-  Hooks/Configure/Post += update_libtool
-  Hooks/InstallDev/Post += libtool_fixup_libdir
+ ifeq ($(filter no-autoreconf,$(PKG_FIXUP)),)
+  Hooks/Configure/Pre += autoreconf
+ endif
 endif
-
 ifneq ($(filter libtool-ucxx,$(PKG_FIXUP)),)
   PKG_BUILD_DEPENDS += libtool
-  Hooks/Configure/Pre += update_libtool_ucxx remove_version_check
-  Hooks/Configure/Post += update_libtool_ucxx
-  Hooks/InstallDev/Post += libtool_fixup_libdir
+ ifeq ($(filter no-autoreconf,$(PKG_FIXUP)),)
+  Hooks/Configure/Pre += autoreconf
+ endif
 endif