[include] autotools.mk: introduce PKG_REMOVE_FILES to delete certain files after...
[openwrt/svn-archive/archive.git] / include / autotools.mk
index fd57e6472747af8cd1bf65b4cbf36e61552f0794..b236aace48b9c644845f77686a38633239d86f58 100644 (file)
@@ -1,30 +1,47 @@
-# 
-# Copyright (C) 2007 OpenWrt.org
+#
+# Copyright (C) 2007-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 
-define replace
-       if [ -f "$(PKG_BUILD_DIR)/$(3)$(1)" -a -e "$(2)/$(1)" ]; then \
-               rm -f $(PKG_BUILD_DIR)/$(3)$(1); \
-               ln -s $(2)/$(1) $(PKG_BUILD_DIR)/$(3); \
-       fi
-       
-endef
+PKG_LIBTOOL_PATHS?=$(CONFIGURE_PATH)
 
-# replace copies of ltmain.sh with the build system's version
-update_libtool=$(call replace,libtool,$(STAGING_DIR)/host/bin,$(CONFIGURE_PATH)/)$(call replace,ltmain.sh,$(STAGING_DIR)/host/share/libtool,$(CONFIGURE_PATH)/)
+autoconf_bool = $(patsubst %,$(if $($(1)),--enable,--disable)-%,$(2))
+
+# delete *.la-files from staging_dir - we can not yet remove respective lines within all package
+# Makefiles, since backfire still uses libtool v1.5.x which (may) require those files
+define libtool_remove_files
+       find $(1) -name '*.la' | $(XARGS) rm -f;
+endef
 
-# prevent libtool from linking against host development libraries
-define libtool_fixup_libdir
-       find $(PKG_BUILD_DIR) -name '*.la' | $(XARGS) \
-               $(SED) "s,^libdir='/usr/lib',libdir='$(strip $(1))/usr/lib',g"
+define autoreconf
+       (cd $(PKG_BUILD_DIR); \
+               $(patsubst %,rm -f %;,$(PKG_REMOVE_FILES)) \
+               if [ -x ./autogen.sh ]; then \
+                       ./autogen.sh || true; \
+               elif [ -f ./configure.ac ] || [ -f ./configure.in ]; then \
+                       [ -f ./aclocal.m4 ] && [ ! -f ./acinclude.m4 ] && mv aclocal.m4 acinclude.m4; \
+                       $(STAGING_DIR_HOST)/bin/autoreconf -v -f -i -s \
+                               -B $(STAGING_DIR)/host/share/aclocal \
+                               $(patsubst %,-I %,$(PKG_LIBTOOL_PATHS)) $(PKG_LIBTOOL_PATHS) || true; \
+               fi \
+       );
 endef
 
+Hooks/InstallDev/Post += libtool_remove_files
+
 ifneq ($(filter libtool,$(PKG_FIXUP)),)
   PKG_BUILD_DEPENDS += libtool
-  Hooks/Configure/Pre += update_libtool
-  Hooks/Configure/Post += update_libtool
-  Hooks/Build/Post += libtool_fixup_libdir
+ ifeq ($(filter no-autoreconf,$(PKG_FIXUP)),)
+  Hooks/Configure/Pre += autoreconf
+ endif
+endif
+ifneq ($(filter libtool-ucxx,$(PKG_FIXUP)),)
+  PKG_BUILD_DEPENDS += libtool
+ ifeq ($(filter no-autoreconf,$(PKG_FIXUP)),)
+  Hooks/Configure/Pre += autoreconf
+ endif
 endif
+