[include] autotools.mk: let PKG_REMOVE_FILES default to aclocal.m4
[openwrt/svn-archive/archive.git] / include / autotools.mk
index b236aace48b9c644845f77686a38633239d86f58..d5f1e464c0c274cc612eba212146a3d75a16665b 100644 (file)
@@ -6,6 +6,7 @@
 #
 
 PKG_LIBTOOL_PATHS?=$(CONFIGURE_PATH)
+PKG_REMOVE_FILES?=aclocal.m4
 
 autoconf_bool = $(patsubst %,$(if $($(1)),--enable,--disable)-%,$(2))
 
@@ -22,6 +23,7 @@ define autoreconf
                        ./autogen.sh || true; \
                elif [ -f ./configure.ac ] || [ -f ./configure.in ]; then \
                        [ -f ./aclocal.m4 ] && [ ! -f ./acinclude.m4 ] && mv aclocal.m4 acinclude.m4; \
+                       [ -d ./autom4te.cache ] && rm -rf autom4te.cache; \
                        $(STAGING_DIR_HOST)/bin/autoreconf -v -f -i -s \
                                -B $(STAGING_DIR)/host/share/aclocal \
                                $(patsubst %,-I %,$(PKG_LIBTOOL_PATHS)) $(PKG_LIBTOOL_PATHS) || true; \
@@ -45,3 +47,8 @@ ifneq ($(filter libtool-ucxx,$(PKG_FIXUP)),)
  endif
 endif
 
+ifneq ($(filter autoreconf,$(PKG_FIXUP)),)
+  ifeq ($(filter autoreconf,$(Hooks/Configure/Pre)),)
+    Hooks/Configure/Pre += autoreconf
+  endif
+endif