kernel: update linux 3.2 to 3.2.13 and refresh patches
[openwrt/svn-archive/archive.git] / include / debug.mk
index 68d70ba093357f799a87ccc3a5121c80f8fa462c..bec74d187a4fd44e50c10932f5706fdb4ff0a663 100644 (file)
@@ -21,8 +21,10 @@ ifeq ($(DUMP),)
   endif
 endif
 
+ifneq ($(DEBUG),)
+
 define debug
-$$(findstring $(2),$$(if $$(DEBUG_DIR),$$(if $$(filter $$(DEBUG_DIR)%,$(1)),$(build_debug)),$(build_debug)))
+$$(findstring $(2),$$(if $$(DEBUG_SCOPE_DIR),$$(if $$(filter $$(DEBUG_SCOPE_DIR)%,$(1)),$(build_debug)),$(build_debug)))
 endef
 
 define warn
@@ -38,4 +40,12 @@ $(call warn,$(1),$(2),$(3)   $(4))
 $(4)
 endef
 
+else
+
+debug:=
+warn:=
+debug_eval:=
+warn_eval = $(4)
+
+endif