[include] ignore vim .swp files when scanning for updates (#7867)
[openwrt/svn-archive/archive.git] / include / depends.mk
index b488af9271893739abd9a24d153ec6c3afc855d0..042fd4f4f28523ac2cc46b21d2f00b8f1a194dc0 100644 (file)
@@ -11,9 +11,9 @@
 #      3: tempfile for file listings
 #      4: find options
 
-DEP_FINDPARAMS := -x "*.svn*" -x ".*" -x "*.svn*" -x "*:*" -x "*\!*" -x "* *" -x "*\\\#*" -x "*/.*_check"
+DEP_FINDPARAMS := -x "*/.svn*" -x ".*" -x "*:*" -x "*\!*" -x "* *" -x "*\\\#*" -x "*/.*_check" -x "*/.*.swp"
 
-find_md5=find $(1) -type f $(patsubst -x,-and -not -path,$(DEP_FINDPARAMS) $(2)) | md5s
+find_md5=$(SH_FUNC) find $(1) -type f $(patsubst -x,-and -not -path,$(DEP_FINDPARAMS) $(2)) | md5s
 
 define rdep
   .PRECIOUS: $(2)
@@ -28,7 +28,7 @@ define rdep
                ) \
                { \
                        [ -f "$(2)_check.1" ] && mv "$(2)_check.1"; \
-                   $(SCRIPT_DIR)/timestamp.pl $(DEP_FINDPARAMS) $(4) -n $(2) $(1) && { \
+                   $(TOPDIR)/scripts/timestamp.pl $(DEP_FINDPARAMS) $(4) -n $(2) $(1) && { \
                                $(call debug_eval,$(SUBDIR),r,echo "No need to rebuild $(2)";) \
                                touch -r "$(2)" "$(2)_check"; \
                        } \