ar71xx: fix AR934X_WMAC_SIZE
[openwrt/svn-archive/archive.git] / include / depends.mk
index 828ceb8564e4c27458fc8eca78ccbc049b484617..14cdcdf7a7b1a74b586785edb010f09154db1dfe 100644 (file)
@@ -11,7 +11,7 @@
 #      3: tempfile for file listings
 #      4: find options
 
-DEP_FINDPARAMS := -x "*/.svn*" -x ".*" -x "*:*" -x "*\!*" -x "* *" -x "*\\\#*" -x "*/.*_check"
+DEP_FINDPARAMS := -x "*/.svn*" -x ".*" -x "*:*" -x "*\!*" -x "* *" -x "*\\\#*" -x "*/.*_check" -x "*/.*.swp"
 
 find_md5=$(SH_FUNC) find $(1) -type f $(patsubst -x,-and -not -path,$(DEP_FINDPARAMS) $(2)) | md5s
 
@@ -20,28 +20,29 @@ define rdep
   .SILENT: $(2)_check
 
   $(2): $(2)_check
+
+ifneq ($(wildcard $(2)),)
+  $(2)_check::
+       $(if $(3), \
+               $(call find_md5,$(1),$(4)) > $(3).1; \
+               { [ \! -f "$(3)" ] || diff $(3) $(3).1 >/dev/null; } && \
+       ) \
+       { \
+               [ -f "$(2)_check.1" ] && mv "$(2)_check.1"; \
+           $(TOPDIR)/scripts/timestamp.pl $(DEP_FINDPARAMS) $(4) -n $(2) $(1) && { \
+                       $(call debug_eval,$(SUBDIR),r,echo "No need to rebuild $(2)";) \
+                       touch -r "$(2)" "$(2)_check"; \
+               } \
+       } || { \
+               $(call debug_eval,$(SUBDIR),r,echo "Need to rebuild $(2)";) \
+               touch "$(2)_check"; \
+       }
+       $(if $(3), mv $(3).1 $(3))
+else
   $(2)_check::
-       if [ -f "$(2)" ]; then \
-               $(if $(3), \
-                       $(call find_md5,$(1),$(4)) > $(3).1; \
-                       { [ \! -f "$(3)" ] || diff $(3) $(3).1 >/dev/null; } && \
-               ) \
-               { \
-                       [ -f "$(2)_check.1" ] && mv "$(2)_check.1"; \
-                   $(TOPDIR)/scripts/timestamp.pl $(DEP_FINDPARAMS) $(4) -n $(2) $(1) && { \
-                               $(call debug_eval,$(SUBDIR),r,echo "No need to rebuild $(2)";) \
-                               touch -r "$(2)" "$(2)_check"; \
-                       } \
-               } || { \
-                       $(call debug_eval,$(SUBDIR),r,echo "Need to rebuild $(2)";) \
-                       touch "$(2)_check"; \
-               }; \
-               $(if $(3), mv $(3).1 $(3);) \
-       else \
-               $(if $(3), rm -f $(3) $(3).1;) \
-               $(call debug_eval,$(SUBDIR),r,echo "Target $(2) not built";) \
-               true; \
-       fi
+       $(if $(3), rm -f $(3) $(3).1)
+       $(call debug_eval,$(SUBDIR),r,echo "Target $(2) not built")
+endif
 
 endef