ep93xx: switch to 3.3 and add broken flag
[openwrt/svn-archive/archive.git] / include / download.mk
index fd197ea2167766ff6de9ee017141e944bf25c0b9..6cc10d95c3057e49fe17454f0873cbc67608b17d 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -45,7 +45,7 @@ define DownloadMethod/default
 endef
 
 define wrap_mirror
-       $(if $(MIRROR),@$(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(FILE)" "x" || ( $(1) ),$(1))
+       $(if $(MIRROR),@$(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(FILE)" "$(MIRROR_MD5SUM)" || ( $(1) ),$(1))
 endef
 
 define DownloadMethod/cvs
@@ -87,7 +87,7 @@ define DownloadMethod/git
                cd $(TMP_DIR)/dl && \
                rm -rf $(SUBDIR) && \
                [ \! -d $(SUBDIR) ] && \
-               git clone $(URL) $(SUBDIR) && \
+               git clone $(URL) $(SUBDIR) --recursive && \
                (cd $(SUBDIR) && git checkout $(VERSION)) && \
                echo "Packing checkout..." && \
                rm -rf $(SUBDIR)/.git && \
@@ -158,6 +158,7 @@ define Download/Defaults
   MD5SUM:=
   SUBDIR:=
   MIRROR:=1
+  MIRROR_MD5SUM:=x
   VERSION:=
 endef