make the compile: host-install dependency independent of the order in which the makef...
[openwrt/svn-archive/archive.git] / include / download.mk
index 406afee48e8139be2e71146ebb531c775b04ab8a..811c42a3c37e249974b76197e4899d34f17ae7f9 100644 (file)
@@ -5,13 +5,13 @@
 # See /LICENSE for more information.
 #
 
-DOWNLOAD_RDEP:=$(STAMP_PREPARED)
+DOWNLOAD_RDEP:=$(STAMP_PREPARED) $(HOST_STAMP_PREPARED)
 
 # Try to guess the download method from the URL
 define dl_method 
 $(strip \
   $(if $(2),$(2), \
-    $(if $(filter @GNU/% @KERNEL/% @SF/% ftp://% http://%,$(1)),default, \
+    $(if $(filter @GNOME/% @GNU/% @KERNEL/% @SF/% ftp://% http://%,$(1)),default, \
       $(if $(filter git://%,$(1)),git, \
         $(if $(filter svn://%,$(1)),svn, \
           $(if $(filter cvs://%,$(1)),cvs, \
@@ -53,7 +53,7 @@ define DownloadMethod/cvs
                 cd $(TMP_DIR)/dl && \
                 rm -rf $(SUBDIR) && \
                 [ \! -d $(SUBDIR) ] && \
-                cvs -d $(URL) co -r $(VERSION) $(SUBDIR) && \
+                cvs -d $(URL) co $(VERSION) $(SUBDIR) && \
                 find $(SUBDIR) -name CVS | xargs rm -rf && \
                 echo "Packing checkout..." && \
                 $(call dl_pack,$(TMP_DIR)/dl/$(FILE),$(SUBDIR)) && \