gcc/musl: rework SSP-support
[openwrt/svn-archive/archive.git] / include / hardening.mk
index 8a24b3ca15e4277aff7794aa6fbc6e0d7680f5b1..c1f0bcb19e404eb35f160052bf1d3375efdb0d2e 100644 (file)
@@ -21,13 +21,11 @@ endif
 ifdef CONFIG_PKG_CC_STACKPROTECTOR_REGULAR
   ifeq ($(strip $(PKG_CC_STACKPROTECTOR_REGULAR)),1)
     TARGET_CFLAGS += -fstack-protector
-    TARGET_LDFLAGS += -fstack-protector
   endif
 endif
 ifdef CONFIG_PKG_CC_STACKPROTECTOR_STRONG
   ifeq ($(strip $(PKG_CC_STACKPROTECTOR_STRONG)),1)
     TARGET_CFLAGS += -fstack-protector-strong
-    TARGET_LDFLAGS += -fstack-protector-strong
   endif
 endif
 ifdef CONFIG_PKG_FORTIFY_SOURCE_1