Add an option to default the default build rule to parallel build.
[openwrt/svn-archive/archive.git] / include / host-build.mk
index 39de66bb9f67407da244e0c000dd5952039220a4..4fd6587aec0a2623eb5b60197c00d6d1d427ce8e 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,13 +7,15 @@
 
 HOST_BUILD_DIR ?= $(BUILD_DIR_HOST)/$(PKG_NAME)$(if $(PKG_VERSION),-$(PKG_VERSION))
 HOST_INSTALL_DIR ?= $(HOST_BUILD_DIR)/host-install
+HOST_BUILD_PARALLEL ?=
+HOST_JOBS ?= $(if $(HOST_BUILD_PARALLEL)$(CONFIG_PKG_DEFAULT_PARALLEL),$(if $(CONFIG_PKG_BUILD_PARALLEL),-j$(CONFIG_PKG_BUILD_JOBS)))
 
 include $(INCLUDE_DIR)/host.mk
 include $(INCLUDE_DIR)/unpack.mk
 include $(INCLUDE_DIR)/depends.mk
 
 BUILD_TYPES += host
-HOST_STAMP_PREPARED=$(HOST_BUILD_DIR)/.prepared$(if $(HOST_QUILT)$(DUMP),,$(shell $(call find_md5,${CURDIR} $(PKG_FILE_DEPEND),)))
+HOST_STAMP_PREPARED=$(HOST_BUILD_DIR)/.prepared$(if $(HOST_QUILT)$(DUMP),,$(shell $(call find_md5,${CURDIR} $(PKG_FILE_DEPENDS),)))
 HOST_STAMP_CONFIGURED:=$(HOST_BUILD_DIR)/.configured
 HOST_STAMP_BUILT:=$(HOST_BUILD_DIR)/.built
 HOST_STAMP_INSTALLED:=$(STAGING_DIR_HOST)/stamp/.$(PKG_NAME)_installed
@@ -36,6 +38,7 @@ define Host/Prepare
 endef
 
 HOST_CONFIGURE_VARS = \
+       CFLAGS="$(HOST_CFLAGS)" \
        CPPFLAGS="$(HOST_CFLAGS)" \
        LDFLAGS="$(HOST_LDFLAGS)" \
        SHELL="$(BASH)"
@@ -54,7 +57,7 @@ HOST_CONFIGURE_ARGS = \
 HOST_CONFIGURE_CMD = ./configure
 
 define Host/Configure/Default
-       @(cd $(HOST_BUILD_DIR)/$(3); \
+       (cd $(HOST_BUILD_DIR)/$(3); \
                if [ -x configure ]; then \
                        $(CP) $(SCRIPT_DIR)/config.{guess,sub} $(HOST_BUILD_DIR)/$(3)/ && \
                        $(2) \
@@ -71,16 +74,25 @@ define Host/Configure
 endef
 
 define Host/Compile/Default
-       $(MAKE) -C $(HOST_BUILD_DIR) $(1)
+       $(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR) $(1)
 endef
 
 define Host/Compile
   $(call Host/Compile/Default)
 endef
 
+define Host/Install/Default
+       $(_SINGLE)$(MAKE) -C $(HOST_BUILD_DIR) install
+endef
+
+define Host/Install
+  $(call Host/Install/Default)
+endef
+
+
 ifneq ($(if $(HOST_QUILT),,$(CONFIG_AUTOREBUILD)),)
   define HostHost/Autoclean
-    $(call rdep,${CURDIR} $(PKG_FILE_DEPEND),$(HOST_STAMP_PREPARED))
+    $(call rdep,${CURDIR} $(PKG_FILE_DEPENDS),$(HOST_STAMP_PREPARED))
     $(if $(if $(Host/Compile),$(filter prepare,$(MAKECMDGOALS)),1),,$(call rdep,$(HOST_BUILD_DIR),$(HOST_STAMP_BUILT)))
   endef
 endif
@@ -94,6 +106,14 @@ define Download/default
   MD5SUM:=$(PKG_MD5SUM)
 endef
 
+define Host/Exports/Default
+  $(1) : export ACLOCAL_INCLUDE=$$(foreach p,$$(wildcard $$(STAGING_DIR_HOST)/share/aclocal $$(STAGING_DIR_HOST)/share/aclocal-*),-I $$(p))
+  $(1) : export STAGING_PREFIX=$$(STAGING_DIR_HOST)
+  $(1) : export PKG_CONFIG_PATH=$$(STAGING_DIR_HOST)/lib/pkgconfig
+  $(1) : export PKG_CONFIG_LIBDIR=$$(STAGING_DIR_HOST)/lib/pkgconfig
+endef
+Host/Exports=$(Host/Exports/Default)
+
 ifndef DUMP
   define HostBuild
   $(if $(HOST_QUILT),$(Host/Quilt))
@@ -106,21 +126,14 @@ ifndef DUMP
        $(call Host/Prepare)
        touch $$@
 
+  $(call Host/Exports,$(HOST_STAMP_CONFIGURED))
   $(HOST_STAMP_CONFIGURED): $(HOST_STAMP_PREPARED)
        $(call Host/Configure)
        touch $$@
 
-  $(HOST_STAMP_BUILT): $(HOST_STAMP_CONFIGURED)
-       $(call Host/Compile)
-       touch $$@
-
-  $(HOST_STAMP_INSTALLED): $(HOST_STAMP_BUILT)
-       $(call Host/Install)
-       mkdir -p $$(shell dirname $$@)
-       touch $$@
-
+  $(call Host/Exports,$(HOST_STAMP_BUILT))
   ifdef Host/Install
-    host-install: $(HOST_STAMP_INSTALLED)
+    host-install: $(if $(STAMP_BUILT),$(HOST_STAMP_BUILT),$(HOST_STAMP_INSTALLED))
   endif
 
   ifndef STAMP_BUILT
@@ -129,8 +142,20 @@ ifndef DUMP
     install: host-install
     clean: host-clean
     update: host-update
+
+    $(HOST_STAMP_BUILT): $(HOST_STAMP_CONFIGURED)
+               $(call Host/Compile)
+               touch $$@
+
+    $(HOST_STAMP_INSTALLED): $(HOST_STAMP_BUILT)
+               $(call Host/Install)
+               mkdir -p $$(shell dirname $$@)
+               touch $$@
   else
-    host-compile: $(HOST_STAMP_INSTALLED)
+    $(HOST_STAMP_BUILT): $(HOST_STAMP_CONFIGURED)
+               $(call Host/Compile)
+               $(call Host/Install)
+               touch $$@
   endif
   host-prepare: $(HOST_STAMP_PREPARED)
   host-configure: $(HOST_STAMP_CONFIGURED)