image: fix handling of per-device kernel build commands
[openwrt/svn-archive/archive.git] / include / host-build.mk
index 126671a0b3d3ce8718c19b022efaf64602ce647a..760d38b371f8fcb6af7acfcc3bd07e65647b0ae6 100644 (file)
@@ -55,7 +55,7 @@ HOST_CONFIGURE_VARS = \
        CFLAGS="$(HOST_CFLAGS)" \
        CPPFLAGS="$(HOST_CPPFLAGS)" \
        LDFLAGS="$(HOST_LDFLAGS)" \
-       SHELL="$(BASH)"
+       SHELL="$(SHELL)"
 
 HOST_CONFIGURE_ARGS = \
        --target=$(GNU_HOST_NAME) \
@@ -73,12 +73,6 @@ HOST_MAKE_FLAGS =
 
 HOST_CONFIGURE_CMD = $(BASH) ./configure
 
-ifneq ($(HOST_OS),Darwin)
-  ifeq ($(CONFIG_BUILD_STATIC_TOOLS),y)
-    HOST_STATIC_LINKING = -static
-  endif
-endif
-
 define Host/Configure/Default
        $(if $(HOST_CONFIGURE_PARALLEL),+)(cd $(HOST_BUILD_DIR)/$(3); \
                if [ -x configure ]; then \
@@ -137,6 +131,7 @@ define Host/Exports/Default
   $(1) : export STAGING_PREFIX=$$(STAGING_DIR_HOST)
   $(1) : export PKG_CONFIG_PATH=$$(STAGING_DIR_HOST)/lib/pkgconfig
   $(1) : export PKG_CONFIG_LIBDIR=$$(STAGING_DIR_HOST)/lib/pkgconfig
+  $(1) : export CCACHE_DIR:=$(STAGING_DIR_HOST)/ccache
 endef
 Host/Exports=$(Host/Exports/Default)
 
@@ -174,6 +169,7 @@ ifndef DUMP
                $(call Host/Install)
                $(foreach hook,$(Hooks/HostInstall/Post),$(call $(hook))$(sep))
                mkdir -p $$(shell dirname $$@)
+               touch $(HOST_STAMP_BUILT)
                touch $$@
 
   ifndef STAMP_BUILT