move host build in packages into a separate namespace: package/<name>/host/<target>
[openwrt/svn-archive/archive.git] / include / host-build.mk
index a0ffd83b6e0bec3145a80f4b22741bfeb8b7bf42..892cde91f5b040b5f1a976b0ec0e4a11665fffd5 100644 (file)
@@ -12,6 +12,7 @@ include $(INCLUDE_DIR)/host.mk
 include $(INCLUDE_DIR)/unpack.mk
 include $(INCLUDE_DIR)/depends.mk
 
 include $(INCLUDE_DIR)/unpack.mk
 include $(INCLUDE_DIR)/depends.mk
 
+BUILD_TYPES += host
 HOST_STAMP_PREPARED=$(HOST_BUILD_DIR)/.prepared$(if $(QUILT)$(DUMP),,$(shell $(call find_md5,${CURDIR} $(PKG_FILE_DEPEND),)))
 HOST_STAMP_CONFIGURED:=$(HOST_BUILD_DIR)/.configured
 HOST_STAMP_BUILT:=$(HOST_BUILD_DIR)/.built
 HOST_STAMP_PREPARED=$(HOST_BUILD_DIR)/.prepared$(if $(QUILT)$(DUMP),,$(shell $(call find_md5,${CURDIR} $(PKG_FILE_DEPEND),)))
 HOST_STAMP_CONFIGURED:=$(HOST_BUILD_DIR)/.configured
 HOST_STAMP_BUILT:=$(HOST_BUILD_DIR)/.built
@@ -122,7 +123,12 @@ ifndef DUMP
     host-install: $(HOST_STAMP_INSTALLED)
   endif
 
     host-install: $(HOST_STAMP_INSTALLED)
   endif
 
-  $(if $(STAMP_BUILT),compile: host-install)
+  ifndef STAMP_BUILT
+    prepare: host-prepare
+    compile: host-compile
+    install: host-install
+    clean: host-clean
+  endif
   host-prepare: $(HOST_STAMP_PREPARED)
   host-configure: $(HOST_STAMP_CONFIGURED)
   host-compile: $(HOST_STAMP_BUILT)
   host-prepare: $(HOST_STAMP_PREPARED)
   host-configure: $(HOST_STAMP_CONFIGURED)
   host-compile: $(HOST_STAMP_BUILT)
@@ -135,10 +141,10 @@ ifndef DUMP
   endef
 
   download:
   endef
 
   download:
-  prepare: host-prepare
-  compile: host-compile
-  install: host-install
-  clean: host-clean
+  prepare:
+  compile:
+  install:
+  clean:
 
 endif
 
 
 endif