add a flag "IGNORE_ERRORS", which can be used to ignore build errors in packages
[openwrt/svn-archive/archive.git] / include / host-build.mk
index 47ec9b0d3a5845a88ab53f6ad2a539e023594cb6..8a8d6dec21a2278dcd51b1a784092100c1c14072 100644 (file)
@@ -12,13 +12,14 @@ include $(INCLUDE_DIR)/host.mk
 include $(INCLUDE_DIR)/unpack.mk
 include $(INCLUDE_DIR)/depends.mk
 
-STAMP_PREPARED:=$(PKG_BUILD_DIR)/.prepared_$(shell find ${CURDIR} $(PKG_FILE_DEPEND) $(DEP_FINDPARAMS) | md5s)
+STAMP_PREPARED=$(PKG_BUILD_DIR)/.prepared$(if $(QUILT)$(DUMP),,$(shell $(call find_md5,${CURDIR} $(PKG_FILE_DEPEND),)))
 STAMP_CONFIGURED:=$(PKG_BUILD_DIR)/.configured
 STAMP_BUILT:=$(PKG_BUILD_DIR)/.built
 STAMP_INSTALLED:=$(STAGING_DIR_HOST)/stamp/.$(PKG_NAME)_installed
 
 override MAKEFLAGS=
 
+include $(INCLUDE_DIR)/download.mk
 include $(INCLUDE_DIR)/quilt.mk
 
 Build/Patch:=$(Build/Patch/Default)
@@ -26,6 +27,7 @@ ifneq ($(strip $(PKG_UNPACK)),)
   define Build/Prepare/Default
        $(PKG_UNPACK)
        $(Build/Patch)
+       $(if $(QUILT),touch $(PKG_BUILD_DIR)/.quilt_used)
   endef
 endif
 
@@ -69,29 +71,25 @@ define Build/Compile
   $(call Build/Compile/Default)
 endef
 
-               
-ifneq ($(strip $(PKG_SOURCE)),)
-  download: $(DL_DIR)/$(PKG_SOURCE)
-
-  $(DL_DIR)/$(PKG_SOURCE):
-       mkdir -p $(DL_DIR)
-       $(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(PKG_SOURCE)" "$(PKG_MD5SUM)" $(PKG_SOURCE_URL)
-
-  $(STAMP_PREPARED): $(DL_DIR)/$(PKG_SOURCE)
-endif
-
 ifneq ($(if $(QUILT),,$(CONFIG_AUTOREBUILD)),)
   define HostBuild/Autoclean
-    $(PKG_BUILD_DIR)/.dep_files: $(STAMP_PREPARED)
     $(call rdep,${CURDIR} $(PKG_FILE_DEPEND),$(STAMP_PREPARED))
-    $(if $(if $(Build/Compile),$(filter prepare,$(MAKECMDGOALS)),1),,$(call rdep,$(PKG_BUILD_DIR),$(STAMP_BUILT),$(PKG_BUILD_DIR)/.dep_files, -and -not -path "/.*" -and -not -path "*/ipkg*"))
+    $(if $(if $(Build/Compile),$(filter prepare,$(MAKECMDGOALS)),1),,$(call rdep,$(PKG_BUILD_DIR),$(STAMP_BUILT)))
   endef
 endif
 
+define Download/default
+  FILE:=$(PKG_SOURCE)
+  URL:=$(PKG_SOURCE_URL)
+  PROTO:=$(PKG_SOURCE_PROTO)
+  VERSION:=$(PKG_SOURCE_VERSION)
+  MD5SUM:=$(PKG_MD5SUM)
+endef
+
 define HostBuild
-  ifeq ($(DUMP),)
-    $(call HostBuild/Autoclean)
-  endif
+  $(if $(QUILT),$(Build/Quilt))
+  $(if $(strip $(PKG_SOURCE_URL)),$(call Download,default))
+  $(if $(DUMP),,$(call HostBuild/Autoclean))
   
   $(STAMP_PREPARED):
        @-rm -rf $(PKG_BUILD_DIR)