add a flag "IGNORE_ERRORS", which can be used to ignore build errors in packages
[openwrt/svn-archive/archive.git] / include / host-build.mk
index c0d62148e881a79af31044df8caddfc1cdb834bc..8a8d6dec21a2278dcd51b1a784092100c1c14072 100644 (file)
@@ -27,6 +27,7 @@ ifneq ($(strip $(PKG_UNPACK)),)
   define Build/Prepare/Default
        $(PKG_UNPACK)
        $(Build/Patch)
+       $(if $(QUILT),touch $(PKG_BUILD_DIR)/.quilt_used)
   endef
 endif
 
@@ -86,6 +87,7 @@ define Download/default
 endef
 
 define HostBuild
+  $(if $(QUILT),$(Build/Quilt))
   $(if $(strip $(PKG_SOURCE_URL)),$(call Download,default))
   $(if $(DUMP),,$(call HostBuild/Autoclean))