add PKG_HOST_ONLY variable to prevent target builds
[openwrt/svn-archive/archive.git] / include / host-build.mk
index 57cb3002b5fa0a2dc212e8be32cce760a1b89f57..a6118fb06f576d0183f5907b4d8f9f69f6be7fc1 100644 (file)
@@ -12,6 +12,7 @@ include $(INCLUDE_DIR)/host.mk
 include $(INCLUDE_DIR)/unpack.mk
 include $(INCLUDE_DIR)/depends.mk
 
+BUILD_TYPES += host
 HOST_STAMP_PREPARED=$(HOST_BUILD_DIR)/.prepared$(if $(QUILT)$(DUMP),,$(shell $(call find_md5,${CURDIR} $(PKG_FILE_DEPEND),)))
 HOST_STAMP_CONFIGURED:=$(HOST_BUILD_DIR)/.configured
 HOST_STAMP_BUILT:=$(HOST_BUILD_DIR)/.built
@@ -96,7 +97,7 @@ endef
 ifndef DUMP
   define HostBuild
   $(if $(QUILT),$(Host/Quilt))
-  $(if $(STAMP_PREPARED),,$(if $(strip $(PKG_SOURCE_URL)),$(call Download,default)))
+  $(if $(if $(PKG_HOST_ONLY),,$(STAMP_PREPARED)),,$(if $(strip $(PKG_SOURCE_URL)),$(call Download,default)))
   $(if $(DUMP),,$(call HostHost/Autoclean))
 
   $(HOST_STAMP_PREPARED):
@@ -122,7 +123,12 @@ ifndef DUMP
     host-install: $(HOST_STAMP_INSTALLED)
   endif
 
-  download:
+  ifndef STAMP_BUILT
+    prepare: host-prepare
+    compile: host-compile
+    install: host-install
+    clean: host-clean
+  endif
   host-prepare: $(HOST_STAMP_PREPARED)
   host-configure: $(HOST_STAMP_CONFIGURED)
   host-compile: $(HOST_STAMP_BUILT)
@@ -134,10 +140,11 @@ ifndef DUMP
 
   endef
 
-  prepare: host-prepare
-  compile: host-compile
-  install: host-install
-  clean: host-clean
+  download:
+  prepare:
+  compile:
+  install:
+  clean:
 
 endif