add PKG_HOST_ONLY variable to prevent target builds
[openwrt/svn-archive/archive.git] / include / host-build.mk
index fdba1b36cbfe44e4e52d0eb70d045bebb4329372..a6118fb06f576d0183f5907b4d8f9f69f6be7fc1 100644 (file)
@@ -1,17 +1,18 @@
-# 
-# Copyright (C) 2006-2008 OpenWrt.org
+#
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 
 HOST_BUILD_DIR ?= $(BUILD_DIR_HOST)/$(PKG_NAME)$(if $(PKG_VERSION),-$(PKG_VERSION))
-PKG_INSTALL_DIR ?= $(HOST_BUILD_DIR)/host-install
+HOST_INSTALL_DIR ?= $(HOST_BUILD_DIR)/host-install
 
 include $(INCLUDE_DIR)/host.mk
 include $(INCLUDE_DIR)/unpack.mk
 include $(INCLUDE_DIR)/depends.mk
 
+BUILD_TYPES += host
 HOST_STAMP_PREPARED=$(HOST_BUILD_DIR)/.prepared$(if $(QUILT)$(DUMP),,$(shell $(call find_md5,${CURDIR} $(PKG_FILE_DEPEND),)))
 HOST_STAMP_CONFIGURED:=$(HOST_BUILD_DIR)/.configured
 HOST_STAMP_BUILT:=$(HOST_BUILD_DIR)/.built
@@ -25,9 +26,8 @@ include $(INCLUDE_DIR)/quilt.mk
 Host/Patch:=$(Host/Patch/Default)
 ifneq ($(strip $(HOST_UNPACK)),)
   define Host/Prepare/Default
-       $(HOST_UNPACK)
+       $(HOST_UNPACK)
        $(Host/Patch)
-       $(if $(QUILT),touch $(HOST_BUILD_DIR)/.quilt_used)
   endef
 endif
 
@@ -35,27 +35,34 @@ define Host/Prepare
   $(call Host/Prepare/Default)
 endef
 
+HOST_CONFIGURE_VARS = \
+       CPPFLAGS="$(HOST_CFLAGS)" \
+       LDFLAGS="$(HOST_LDFLAGS)" \
+       SHELL="$(BASH)"
+
+HOST_CONFIGURE_ARGS = \
+       --target=$(GNU_HOST_NAME) \
+       --host=$(GNU_HOST_NAME) \
+       --build=$(GNU_HOST_NAME) \
+       --program-prefix="" \
+       --program-suffix="" \
+       --prefix=$(STAGING_DIR_HOST) \
+       --exec-prefix=$(STAGING_DIR_HOST) \
+       --sysconfdir=$(STAGING_DIR_HOST)/etc \
+       --localstatedir=$(STAGING_DIR_HOST)/var
+
+HOST_CONFIGURE_CMD = ./configure
+
 define Host/Configure/Default
        @(cd $(HOST_BUILD_DIR)/$(3); \
-       [ -x configure ] && \
-               $(CP) $(SCRIPT_DIR)/config.{guess,sub} $(HOST_BUILD_DIR)/$(3)/ && \
-               $(2) \
-               CPPFLAGS="$(HOST_CFLAGS)" \
-               LDFLAGS="$(HOST_LDFLAGS)" \
-               SHELL="$(BASH)" \
-               ./configure \
-               --target=$(GNU_HOST_NAME) \
-               --host=$(GNU_HOST_NAME) \
-               --build=$(GNU_HOST_NAME) \
-               --program-prefix="" \
-               --program-suffix="" \
-               --prefix=$(STAGING_DIR_HOST) \
-               --exec-prefix=$(STAGING_DIR_HOST) \
-               --sysconfdir=$(STAGING_DIR_HOST)/etc \
-               --localstatedir=$(STAGING_DIR_HOST)/var \
-               $(DISABLE_NLS) \
-               $(1); \
-               true; \
+               if [ -x configure ]; then \
+                       $(CP) $(SCRIPT_DIR)/config.{guess,sub} $(HOST_BUILD_DIR)/$(3)/ && \
+                       $(2) \
+                       $(HOST_CONFIGURE_CMD) \
+                       $(HOST_CONFIGURE_VARS) \
+                       $(HOST_CONFIGURE_ARGS) \
+                       $(1); \
+               fi \
        )
 endef
 
@@ -87,11 +94,12 @@ define Download/default
   MD5SUM:=$(PKG_MD5SUM)
 endef
 
-define HostBuild
+ifndef DUMP
+  define HostBuild
   $(if $(QUILT),$(Host/Quilt))
-  $(if $(strip $(PKG_SOURCE_URL)),$(call Download,default))
+  $(if $(if $(PKG_HOST_ONLY),,$(STAMP_PREPARED)),,$(if $(strip $(PKG_SOURCE_URL)),$(call Download,default)))
   $(if $(DUMP),,$(call HostHost/Autoclean))
-  
+
   $(HOST_STAMP_PREPARED):
        @-rm -rf $(HOST_BUILD_DIR)
        @mkdir -p $(HOST_BUILD_DIR)
@@ -110,23 +118,33 @@ define HostBuild
        $(call Host/Install)
        mkdir -p $$(shell dirname $$@)
        touch $$@
-       
+
   ifdef Host/Install
-    install: $(HOST_STAMP_INSTALLED)
+    host-install: $(HOST_STAMP_INSTALLED)
   endif
 
-  package-clean: FORCE
+  ifndef STAMP_BUILT
+    prepare: host-prepare
+    compile: host-compile
+    install: host-install
+    clean: host-clean
+  endif
+  host-prepare: $(HOST_STAMP_PREPARED)
+  host-configure: $(HOST_STAMP_CONFIGURED)
+  host-compile: $(HOST_STAMP_BUILT)
+  host-install:
+  host-clean: FORCE
        $(call Host/Clean)
        $(call Host/Uninstall)
-       rm -f $(HOST_STAMP_INSTALLED) $(HOST_STAMP_BUILT)
+       rm -rf $(HOST_BUILD_DIR) $(HOST_STAMP_INSTALLED) $(HOST_STAMP_BUILT)
+
+  endef
 
   download:
-  prepare: $(HOST_STAMP_PREPARED)
-  configure: $(HOST_STAMP_CONFIGURED)
-  compile: $(HOST_STAMP_BUILT)
+  prepare:
+  compile:
   install:
-  clean: FORCE
-       $(call Host/Clean)
-       rm -rf $(HOST_BUILD_DIR)
+  clean:
+
+endif
 
-endef