ar71xx: add Netgear WNR1000v2/WNR1000v2-VC support (#18633)
[openwrt/svn-archive/archive.git] / include / host-build.mk
index 60b7b9f916df771899038d1e3adecfced8d2ccad..ad821f72c41a23e6e35704e07a51ee7818e76cfb 100644 (file)
@@ -71,7 +71,7 @@ HOST_CONFIGURE_ARGS = \
 
 HOST_MAKE_FLAGS =
 
 
 HOST_MAKE_FLAGS =
 
-HOST_CONFIGURE_CMD = ./configure
+HOST_CONFIGURE_CMD = $(BASH) ./configure
 
 ifneq ($(HOST_OS),Darwin)
   ifeq ($(CONFIG_BUILD_STATIC_TOOLS),y)
 
 ifneq ($(HOST_OS),Darwin)
   ifeq ($(CONFIG_BUILD_STATIC_TOOLS),y)
@@ -164,42 +164,32 @@ ifndef DUMP
        touch $$@
 
   $(call Host/Exports,$(HOST_STAMP_BUILT))
        touch $$@
 
   $(call Host/Exports,$(HOST_STAMP_BUILT))
-  ifdef Host/Install
-    host-install: $(if $(STAMP_BUILT),$(HOST_STAMP_BUILT),$(HOST_STAMP_INSTALLED))
-  endif
-
-  ifndef STAMP_BUILT
-    prepare: host-prepare
-    compile: host-compile
-    install: host-install
-    clean: host-clean
-    update: host-update
-    refresh: host-refresh
-
-    $(HOST_STAMP_BUILT): $(HOST_STAMP_CONFIGURED)
+  $(HOST_STAMP_BUILT): $(HOST_STAMP_CONFIGURED)
                $(foreach hook,$(Hooks/HostCompile/Pre),$(call $(hook))$(sep))
                $(call Host/Compile)
                $(foreach hook,$(Hooks/HostCompile/Post),$(call $(hook))$(sep))
                touch $$@
 
                $(foreach hook,$(Hooks/HostCompile/Pre),$(call $(hook))$(sep))
                $(call Host/Compile)
                $(foreach hook,$(Hooks/HostCompile/Post),$(call $(hook))$(sep))
                touch $$@
 
-    $(HOST_STAMP_INSTALLED): $(HOST_STAMP_BUILT) $(if $(FORCE_HOST_INSTALL),FORCE)
+  $(HOST_STAMP_INSTALLED): $(HOST_STAMP_BUILT) $(if $(FORCE_HOST_INSTALL),FORCE)
                $(call Host/Install)
                $(foreach hook,$(Hooks/HostInstall/Post),$(call $(hook))$(sep))
                mkdir -p $$(shell dirname $$@)
                $(call Host/Install)
                $(foreach hook,$(Hooks/HostInstall/Post),$(call $(hook))$(sep))
                mkdir -p $$(shell dirname $$@)
+               touch $(HOST_STAMP_BUILT)
                touch $$@
                touch $$@
-  else
-    $(HOST_STAMP_BUILT): $(HOST_STAMP_CONFIGURED) $(if $(FORCE_HOST_INSTALL),FORCE)
-               $(foreach hook,$(Hooks/HostCompile/Pre),$(call $(hook))$(sep))
-               $(call Host/Compile)
-               $(foreach hook,$(Hooks/HostCompile/Post),$(call $(hook))$(sep))
-               $(call Host/Install)
-               $(foreach hook,$(Hooks/HostInstall/Post),$(call $(hook))$(sep))
-               touch $$@
+
+  ifndef STAMP_BUILT
+    prepare: host-prepare
+    compile: host-compile
+    install: host-install
+    clean: host-clean
+    update: host-update
+    refresh: host-refresh
   endif
   endif
+
   host-prepare: $(HOST_STAMP_PREPARED)
   host-configure: $(HOST_STAMP_CONFIGURED)
   host-prepare: $(HOST_STAMP_PREPARED)
   host-configure: $(HOST_STAMP_CONFIGURED)
-  host-compile: $(HOST_STAMP_BUILT)
-  host-install:
+  host-compile: $(HOST_STAMP_BUILT) $(if $(STAMP_BUILT),$(HOST_STAMP_INSTALLED))
+  host-install: $(HOST_STAMP_INSTALLED)
   host-clean: FORCE
        $(call Host/Clean)
        $(call Host/Uninstall)
   host-clean: FORCE
        $(call Host/Clean)
        $(call Host/Uninstall)