[kernel] accomodate netfilter module (xt_recent) name change in 2.6.28, add missing...
[openwrt/svn-archive/archive.git] / include / host-build.mk
index 3d1983b28f37091d51e342f636bf7c1154831c4f..ffba12b51d2fcbfae7a4ab242bc5793bb9e662ad 100644 (file)
@@ -78,6 +78,15 @@ define Host/Compile
   $(call Host/Compile/Default)
 endef
 
+define Host/Install/Default
+       $(MAKE) -C $(HOST_BUILD_DIR) install
+endef
+
+define Host/Install
+  $(call Host/Install/Default)
+endef
+
+
 ifneq ($(if $(HOST_QUILT),,$(CONFIG_AUTOREBUILD)),)
   define HostHost/Autoclean
     $(call rdep,${CURDIR} $(PKG_FILE_DEPEND),$(HOST_STAMP_PREPARED))
@@ -128,6 +137,7 @@ ifndef DUMP
     compile: host-compile
     install: host-install
     clean: host-clean
+    update: host-update
   else
     host-compile: $(HOST_STAMP_INSTALLED)
   endif